PDA

View Full Version : EcoTech Marine


Pages : 1 2 3 4 5 6 [7] 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31

  1. SoCal Tropical Fish/Ecotech Service is the Best!
  2. mp20 thumping noise???
  3. mp20 thumping noise???
  4. upgrading 20 to 40, do i need new power adasptor?
  5. Solid Red
  6. MP40w-New GEN 3 version
  7. New MP10 noise level???
  8. vortech drivers/controller
  9. Mp20 not functioning correctly
  10. Driver got wet
  11. MP10 Enough Flow For Me?
  12. MY 40 is making a a lot of noise
  13. Wet side part question
  14. mp20 or mp40
  15. ETA for MP10s???
  16. VorTech Battery Backup
  17. Is it worth it?
  18. Tech series tanks
  19. anyone with 2 X MP40w's ina 90 gallon? also a Battery backup question.
  20. too much flow planned...?
  21. stop production of MP20
  22. Not pumping as strong as I thought it should have
  23. 40g breeder pump suggestions.
  24. Red and Orange Flashing?
  25. Magnet
  26. mp40w placement and wave help
  27. Moving Vortech mp40w Location
  28. mp40w falling off glass
  29. MP10 Update
  30. need help with mp40w
  31. mp40w not working
  32. WWD flashing Red
  33. MP40W Fell Apart
  34. Some MP20 Questions
  35. mp20 help
  36. Drive Shaft?
  37. MP40 Gen 1 to Gen 2
  38. MP40W placement 48x28x24
  39. MP40W DC power supply
  40. Need Service? We Prefer You Contact Us Directly (click for details)
  41. Kudos to steve and the ecotech brand
  42. new impellars for mp40w how much?
  43. Replacing the Tuzes and adding another Vortech today!
  44. Plastic washer
  45. Power Supply
  46. Videos of 6 ft long 150G tank with single MP40
  47. Dry side magnet
  48. How Noisy Should An MP40W Be?
  49. You need Vortech power baby!
  50. Pump Going Through Color Loop
  51. MP10: 200 GPH or 500 GPH ?
  52. MP10: 10mm?
  53. anti sync
  54. MP40 Issues
  55. Flashing Red light???
  56. MP20 upgrade
  57. How to Mount MP40 Wave Driver
  58. MP20 to MP40W driver upgrade now I have some issues..
  59. will an MP20 be sufficient for
  60. Question
  61. Master/Slave Settings? and Manual?
  62. MP20 problem
  63. New MP10 Update AND Videos
  64. MP40w stuck in Upgrade Slave mode - HELP!
  65. will this affect mp40w performance?
  66. MP40W problem
  67. Mode of choice?
  68. More problems with my MP20
  69. Pin Spacer Melting
  70. Turn Off Night Mode
  71. stopage..
  72. Mp10
  73. Battery Back-Up Cord
  74. vortech issue
  75. mp40 wet side failure!
  76. EcoTech Excellent Customer Service!!
  77. Cable problem
  78. Pin Spacer. I pealed sticker off...
  79. dry side noticeably hotter than other pumps?
  80. Dry side hot
  81. mp40w
  82. MP10's are shipping!
  83. Red Blinking Light
  84. Vortech + sand=Tornado
  85. problem with MP40 wetside
  86. MP40 seperation problem
  87. MP10 - Mini Review - Unboxing and VIDEO
  88. i need some parts where can i buy
  89. No Power on MP40
  90. Mp10 on a 29g?
  91. Power supplied died
  92. mp40w wet side failure again
  93. battery backup compatablility
  94. MP40w on a UPS?
  95. Should the filled spot on the intakes be facing anywhere?
  96. mp40 to mp40w upgrade
  97. Customer Service
  98. Rubber spacer needed?
  99. Excellent Customer Service
  100. MP10 Impressive
  101. Just got pump back from repair and it still doesn't work!!
  102. MP20 Power Supply
  103. need a snail guard!
  104. night mode/disconnect calibration?
  105. Noise level on my MP10
  106. July 4th Holiday
  107. Thank you for Excellent Support
  108. Wave
  109. mp40w broke.
  110. Elos e-Lite Marine
  111. MP 10 Pre-order Status
  112. MP20 Problem
  113. MP-10 foam cover
  114. New plastic coated magnets defective??
  115. Sugar Size Sand & Vortech
  116. MP10 on 5/8'' Glass?
  117. Seperation question
  118. I have an MP10 and you don't!
  119. MP40w Amp Draw?
  120. Help, MP40 just stopped working
  121. big thanks
  122. wetside slipping off
  123. EcoTech is topnotch!
  124. MP10 & Acrylic Tank
  125. I joined the MP40W club last night
  126. Mp40w Problem
  127. Power supply death
  128. Email hasn't been returned..
  129. MP40W --- Wetside Positioning
  130. rubber gasket
  131. Does the mp40 come with a sponge?
  132. MP40 Questions
  133. Pulse Mode Problem?
  134. I visited EcoTech Marine today!
  135. Multiple program ability?
  136. Pump has started falling off glass
  137. MP40w's making a whistling noise
  138. Battery back up questions
  139. mp 40 spare parts
  140. customer service - much to be desired
  141. Just Bought a New MP10!
  142. Vortech for BB 110g
  143. Water + Vortech -> CS?
  144. How do I know if I have a Gen2 Mp40w and not Gen1?
  145. What wave mode do you use ?
  146. MP40w Placement?
  147. Vortech mp40w heat?
  148. Extending the cord ????
  149. Battery Backup cable
  150. MP 20 on a 3ft cube
  151. Not Again
  152. Where can buy MP10 now ?
  153. MP40 wetside will not sync
  154. Mp40w Controller
  155. Dry side of my mp20 fell in h20..for 20 min.. any chance of survival?
  156. Battery Backup compatibility with MP10
  157. mp10 to supplement flow in my 90g???
  158. Plastic Nut
  159. 12mm glass
  160. Best customer service EVER.
  161. Brand New MP40W NOT WORKING :(
  162. mp10 running a little hot
  163. tranformer quit working , use BB instead?
  164. How often?
  165. 3/4 thick acrylic?
  166. who do i see for a warranty claim?
  167. Vortech mp40 placement help
  168. MP20 Upgrade to MP40W Question
  169. Controller doesn't power up anymore ?
  170. New MP40W gen 2 falling off
  171. solid red light
  172. Why does the cord have to be up?
  173. MP20 or MP10
  174. Battery Backup Damaged during shipping (pics)
  175. Propeller not turning with magnet?
  176. New MP10 - Spacer
  177. MP10 in an Aquapod 24
  178. Mp20 to mp40 upgrade
  179. Wireless Communication Issue
  180. MP40W not working Flashing Red
  181. MP40W and controller question
  182. Great Customer Service.
  183. MP10 is AWESOME!
  184. ecotech service
  185. MP-10 Question
  186. in reef or lagoon mode red light
  187. mp40w flashing red
  188. anyone use a dry box for the mp-10s?
  189. Vortech nut. How tight
  190. MP40 instruction book?
  191. MP 20 driver
  192. MP40w night mode issue
  193. MP40W's keep having issues
  194. Feed Mode Not Working
  195. You Already Know This, But...
  196. MP40W- Keeps falling off the glass
  197. 2 years without stopping!
  198. MP40 high pitched noise
  199. mp 40 driver on a mp20 ?
  200. Which vortech for 46 bow front
  201. To sync or not to sync, that is the question???
  202. MP40W working like a charm
  203. keeps falling off
  204. What should I do with this MP20?
  205. MP10 Driver Issue
  206. Gen2 or not
  207. make a wave in tank
  208. MP20 Issue
  209. No spin on battery back-up
  210. Pairing a 40 with a 20 -- good or bad idea?
  211. MP40 keeps Stalling
  212. MP 10 question
  213. Is the Dry Gasket Really Necessary?
  214. New bearings/shaft
  215. New Vortech owner
  216. mp10 long pulse mode
  217. 40 breeder?
  218. MP20 not working again
  219. Do these puppies ever go on sale?
  220. Turning off MP40 for feeding
  221. World's only defective MP 10 pump?
  222. 150 gallon 60" tank, thoughts?
  223. best mounting location?
  224. MP40 Driveshaft wear
  225. Tim -- do you offer refurbs at a discount?
  226. Vortech too hot to the touch
  227. Which Vortech for a DSA Neo Nano?
  228. MP 40 need help
  229. MP40 still going strong
  230. Warranty
  231. mp40w issues
  232. Problem with outlet grate
  233. Need some advice about adding 2nd MP40
  234. Which Vortech to use
  235. MP20 upgrade?
  236. Modification on a mp20
  237. Extending pump motor wires
  238. Sync/Anti in Reefcrest & Lagoon mode?
  239. MP40 Chattering
  240. Pin Spacer
  241. larger model
  242. MP40W stalls when I try to set night mode.
  243. one of my mp40 has a whine..what can i do??
  244. chatter after cleaning
  245. Tank thickness
  246. Problems with MP40W holding on Oceanic 120 Tech tank
  247. VorTech MP10 and Battery Backup
  248. Dry Side Got Wet
  249. new wet side required before servicing?
  250. MP40w x2 Maintenance mode