PDA

View Full Version : EcoTech Marine


Pages : 1 2 3 4 5 6 7 8 [9] 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31

  1. MP 10 coming in for warranty work
  2. Excellent Customer Service
  3. Wet side falling off
  4. wetside direction
  5. Which Vortech?
  6. MP40W and 3/4" glass
  7. I love my Vortech so much I made a ....
  8. Which pin spacer setting should I use (5/16" glass)
  9. Future models for 1" tanks
  10. New MP10 on my JBJ NC 28g
  11. Battery Backup power supply
  12. New MP10 just came in...
  13. MP10 on PVC surface.
  14. Cord Mounting tabs
  15. MP40W wetside locking
  16. Is setting the glass thickness really that important?
  17. Which VorTech for 26" Cube Tank
  18. rattling and squealing wetside
  19. Video Contest Winner Announcement!
  20. MP40 issues
  21. Settings question
  22. mp40 power supply needed
  23. gen 1 mp40 wet side problem
  24. Brand New MP10 Failure
  25. Hats off to EcoTech
  26. old wet side problem
  27. New mp40w's on the way
  28. Question: MP10 + JBJ Picotope
  29. MP20 shuts down occassionally
  30. dose anybody care at this co.
  31. Odd error colours
  32. Flow?
  33. ceramic bearing
  34. suggestion for ecotech
  35. Spare wetside
  36. Wet Side makes noise and quit spinning
  37. problem with my battery back up.
  38. Blinking Green
  39. Used Mp40w not working!
  40. Dry side noise
  41. MP20 / Loss of flow w/ foam cover
  42. Stall condition
  43. Sponsorship request...
  44. mp20 -wave
  45. MP40W rattling on low setting
  46. first gen 2nd gen compatable?
  47. Battery Backup Not Working
  48. How much space around MP10 Wetside?
  49. mp10 works with battery backup?
  50. Enough flow???
  51. inactivate indicator light
  52. So why does my pump keep dropping off?
  53. From your FRUSTRATED customer!
  54. can a mp40w and a mp20 work together?
  55. in tank 2 weeks and the wetside falls off
  56. MP20 Wetside
  57. Broken vortech MP20?
  58. Broken MP20 works then shuts off
  59. paint on dryside magnets bubbled and peeling.
  60. So... how much to upgrade?
  61. constant red light/impeller not working?
  62. Help positioning Mp10 and Mp20
  63. HELP Please....MP10 Flashing Green Light???
  64. What would be ideal for this all vortech tank?
  65. MP40 make too much noise!
  66. MP40 help - controller malfunctions
  67. Warranty
  68. Excellent customer service!
  69. Holiday Hours - we will not be responding to this forum as frequently
  70. Battery Backup Problems
  71. Issue with one of my Wetsides
  72. Have I mentioned how great the customer service is?!
  73. HELP! My new Vortech MP20 is flashing green and quit working
  74. Help MP10 soaked...
  75. is the propellar covered?
  76. MP40 on Painted Glass
  77. 29 Gallon Biocube, what size Vortech?
  78. Vortech and Top off
  79. Syncronizing MP40
  80. Is it normal or?
  81. Need new power cord
  82. MP40 placement recommendations...
  83. Anyone else running an mp40 on the bottom of the tank pointing up?
  84. Frustrated...
  85. Modifying the ORIGINAL controller.
  86. placement question
  87. When will the 40 be controllable with an Apex?
  88. MP40 rattle
  89. Dead power supply...Options?
  90. Flow advice for 2 different cubes
  91. Broken mp40
  92. mp 40 ?
  93. Mp40W very noisy on the dry side
  94. Mp40 problems
  95. pin spacer
  96. MP10 and no break
  97. Silent Treatment From Echo Tech Marine
  98. cleaning an MP40W
  99. No Pin Spacer Guide
  100. MP10 Use the spacer or not?
  101. No serial number?
  102. when should i expect a response?
  103. Thickest size acrylic a MP40w will work on?
  104. MP40W Not Creating Enough Flow
  105. waiting for call back since tuesday..
  106. Good Service
  107. Bad service. Where is my pump?
  108. what does a continuous green blinking light mean?
  109. MP20 Keeps Stalling/Random Shut Off
  110. Refurb pumps
  111. how many in a a90
  112. Shaft Broken at the Magnet on Wetside
  113. Removing cord holder
  114. (2) Wet sides status from 1.5 weeks ago?
  115. red flashing overheat sign please help
  116. vortech flashing red and white
  117. Any #s on gal/hr in the diff mode settings?
  118. Positioning tips
  119. First experience with Ecotech Customer Service...so far so good!
  120. Trouble with pump
  121. Under year old mp20 stalling.
  122. new mp10
  123. Glass thickness?
  124. Will an MP20 create a wave in a 36x24x30 tank?
  125. Had my MP20 serviced...
  126. Stand-By Mode
  127. Brand New MP10 Not Working!
  128. where to get MP40 parts
  129. Maybe Need Servicing Mp40w/Someone from Ecotech
  130. Mp60
  131. MP10 noise level increase
  132. confused about service
  133. vortech recommendations.
  134. Vibration even though centered
  135. MP20 converted to MP40 Serial#???
  136. MP40W Driveshaft broken / scoring on magnet
  137. MP40 Gen 1 startup/stalling issues
  138. Flashing Red and Purple
  139. warranty
  140. EcoTech Customer Service Rocks!!!!!
  141. please provide tracking number
  142. mp 40 Sqeaking
  143. mp 40 wave
  144. mp40w calibration problem
  145. i have a bound/tight mp40w
  146. Cleaning MP40W
  147. Battery Backup Failure
  148. MP10-Batter Backup?
  149. MP 40 and MP20 question
  150. Any heat issues?
  151. Vortech mp40w vibration issues
  152. Mp20 shuts down
  153. Two MP40ws not running equally
  154. Good repair experience.
  155. MP10 - Flashing Red/Green
  156. MP40 help! I only have 3 colors on the controller
  157. Help MP20 Just Snapped!?
  158. good customer service
  159. Great customer service
  160. When to buy MP20?
  161. MP10 vs. MP20
  162. Dry side rattle
  163. Vortechs + RKL?
  164. mp40w not working
  165. This is why I buy from EcoTech A+ Customer Service
  166. MP10 sounds like a car engine
  167. Power Supply Failure
  168. mp40w will not run in reef crest mode
  169. Another "great customer service" thread
  170. Broken wet side
  171. MP40w problem
  172. MP40w flashing red
  173. VorTechs for 185 gal
  174. Damaged MP40?
  175. Need rubber gasket
  176. Spacer question?
  177. Magnet Strenght Loss?
  178. MP40 - confused
  179. Most Flow
  180. Rattling at certain speeds
  181. need powerheads. Sell me on the P40 over Tunze 6105's
  182. Great service - AGAIN - thanks!
  183. Inspection
  184. Dry side question
  185. Question about programmability of vortech pumps
  186. Problems
  187. Need help with separating rotor from wet frame base.
  188. mp10 problem with long pulse mode
  189. upgrade mp20 to an mp40?
  190. New MP10 - Rubber Spacer on BC29?
  191. Problem with MP10
  192. MP20 or MP40W for 65g?
  193. Battery Back-Up; Please Help!
  194. mp10 broke (need help please)
  195. Disappointment
  196. what the difference in the mp40 gen1 to gen2
  197. Problem with Vortech
  198. Tracking number?
  199. help! lost the nut from my wetside during a cleaning!
  200. Status
  201. Wave questions
  202. Wet side/dry side separation?
  203. Whats next from Ecotech?
  204. New Battery Backup
  205. EcoTech Marine's New Battery Backup
  206. Burnt power supply
  207. Wet end issue
  208. lagoon, reef crest or night with dial at minimum
  209. Your Customer Service Exceded Expectations!
  210. Confirming gen 2's and question about warranty
  211. Which Pump ? Mp10 or MP20 ?
  212. Pump seizing up and falling off
  213. No Reply
  214. Need a part
  215. MP40w in Stall condition.
  216. Love hate relationship
  217. Need white washer (bearing)
  218. Great service, thanks
  219. What sand do you use with your vortech?
  220. Need Extra Foam Covers for MP10
  221. MP40w During Water Changes
  222. How many wetsides does it take to keep these running?
  223. Will you eventually make the MP10 wireless?
  224. mp40 or two mp10
  225. Need Repairs Done
  226. WTB: driver and PS left over from MP20 to MP40 upgrade
  227. MP40 Water Damage...
  228. Issues with MP10...
  229. Will MP10 work on 1/2" glass?
  230. Squealing wet end
  231. Loud!
  232. Online Parts Store Coming Soon!!
  233. To buy or not to buy
  234. Parts Shipping
  235. MP40 shines
  236. Upgrade mp20 to mp40w - Wireless wawe driver
  237. Mp20 or mp40??
  238. Need some help...burned up 2 Vortech power supplies!
  239. MP40w blinking red/white
  240. mp40w loud?
  241. New MP40W's noise
  242. wet n dry side disconected now nothing works
  243. Wetside impeller came off?
  244. 75g mp10 or 20
  245. Spacer with mp10 on nano cube
  246. Pump Disconect Calibration (help)
  247. 24" cube...what's right for me?
  248. Bad Smell
  249. Wireless MP10
  250. vibration and parts ?