PDA

View Full Version : What Do I have?


trlrider77
04/10/2007, 10:47 PM
I just got a piece with at least 20 rics attached. They were supposed to be rics anyway. My question is what exactly are they?. I have them less that a third up in my 110 with 2 175W mh. Is this too much light? I had them on the sand but they were getting too much flow and not opening up very good.

IMG]http://i84.photobucket.com/albums/k18/trlrider77/Ric.jpg[/IMG]

Next. I also would like to know what kind of mushrooms these are. There are 6 on this piece. I got this out of the frag tank at my LFS. Not too bad for $20 I don't think. Thanks to any and all who respond.

http://i84.photobucket.com/albums/k18/trlrider77/Mushroom.jpg

trlrider77
04/10/2007, 10:47 PM
First pic didn't post right.

http://i84.photobucket.com/albums/k18/trlrider77/Ric.jpg

circusordie16
04/10/2007, 11:10 PM
it looks like both of the pictures are rics. the ones in your last post are yumas and the ones in your first post look like ricordea floridas. yumas generally dont need too much light so you could move them somewhere shadier or theyll probably adjust in time.

ntfish
04/11/2007, 08:10 AM
Those yumas don't look happy. Best move them to low light and low current and hope for the best.

trlrider77
04/11/2007, 06:14 PM
Yeah they're not happy at all. I think I may have lost a few. I looked after work and it seems a few of them have melted away. I guess this is what's happening. They have a brown slime look to them. i will move them to a lower light place. Thanks for the replys.