PDA

View Full Version : External access via the Internet


conny737
01/20/2008, 12:03 PM
Anyone who has made a successful connection to the profilux via the Internet? My WLAN card is set up properly and works fine at home.
As for access remotely (via Internet) I have not done more than setting up a dynamic dns.
Not quite sure how to proceed from there. Maybe someone has some kind of step by step instructions? I have a router with firewall (Netgear) at home.
Just a shot in the dark to avoid a lot of unneccesary failures....

elzool
01/20/2008, 12:19 PM
This (http://portforward.com/routers.htm) site seems to have good info on port forwarding. See if your model is there and set up port forwarding. Several programs it lists have the same instructions on setting up your router. The port you want to forward is 10001. Forward that port to the ip address of your Profilux.

Then, install Profilux control on the machine you want to access it and set up tcp/ip to your external ip address. That ought to do it.

conny737
01/21/2008, 02:26 AM
Thanks, now I have made the settings in the router. But as a novice regarding networks I´m rather unsure how to proceed.

When I type in the dyndns I got, what should I see? As of now I just get the irritating "this page cannot be displayed"

I can access the router for remote settings, but that is not what I want.

My "network" consists of a Wireless router which connects my computers to the internet. I have not made any sharing settings. But Profilux control software is installed on all machines and works fine on WLAN.

Ive searched the internet for answers, but can´t find anything useful regarding this matter.
Maybe its time to dig into some manuals...

elzool
01/21/2008, 08:11 AM
If you set up the port forwarding, then all you need to do is install Profilux control on a computer outside your network.

You can't use a browser to connect to your Profilux, thats probably where you are getting the Page cannot be displayed message at right?

In Profilux control at Communication/Connection click the button with three dots. At the Connections pop up there should already be a TCP/IP listing there, double click that and change the host name to whatever your dyndns name is, set to port 10001 and uncheck search automatically. Save that and connect via tcp/ip.

That ought to do it.

conny737
01/21/2008, 10:54 AM
:dance:Eureka!! It works!

Thank you very much elzool for helping me out with this one!!
I was really stuck in my thinking as how to connect. Didn´t realize I should go via the program. Maybe rather basic, but there are some black holes in my computer knowledge.
Anyway, thanks again.

elzool
01/21/2008, 12:00 PM
heh... no worries, glad it worked out!

erikages
01/24/2008, 09:09 PM
Thanks for the tips: I got it working, too!

A few questions: when I link via tcp, it simply asks for the standing dns (192.168.1.105, which is what I've got established for the Profilux in my router). Will this work if I'm accessing the Profilux from another network in another location? Doesn't seem like it would.

Secondly, what about security issues? If this port forwarding mechanism allows an "in," are other computers and the router itself at risk of being highjacked?

Thanks,
Erik

conny737
01/25/2008, 04:31 AM
Well, my happy state didn´t last long.

The day after my successful attempt to connect from the "outside", the not so fun message "unable to connect, do you want to check you settings?" appeared when I tried to connect. I am able to ping both the router and the Profilux externally, but when I run Profilux control it won´t connect.

Have increased the timeout settings, but no joy. A strange thing is that I have been able to connect two times, but when I disconnected and tried to connect again it didn´t work.

Maybe it has to do something with the Internet connection speed which I use to connect from the outside. It has only a speed of around 350 kbps. Might be to slow?

If you want to connect to the computer i think the only way is to get a static IP from your ISP or to get a dynamic DNS (which I did).

I have also been a little bit concerned about the security issue, but I hope nobody is interested in hacking an aquarium..

Anyway I use a DYnDNS, configured the router to block everything except calls on the Profilux. So the Profilux is the only thing visble from the outside.

Matthias Gross
01/25/2008, 08:19 AM
did you maybe play with the baudrates?
Port 10001 ok?

conny737
01/25/2008, 09:28 AM
Nope, baud rate is grayed out, so I havn´t done anything with that setting in the program.
I have also set the router for port forwarding to port 10001. And I pinged the port from the Internet, getting the message that the port is open.
Ocassionally I can get connected, but after disconnecting it is not possible to connect again.

Using the "outside" communication setup in Profilux control works when I am at home (also the "normal" WLAN connection works fine), but once outside I cant get through (most of the time).

best regards

Matthias Gross
01/25/2008, 10:00 AM
maybe your router holds the connection open between router and ProfiLux even if there is no external access any more?

What happens after reset of the router? Is then again a connection possible?

conny737
01/29/2008, 04:28 AM
Thanks for your reply Matthias,
The symptoms might indicate that the router keeps the line open even if disconnected, but I`m not quit sure why it would do that.

I have now tried three different routers (Netgear, DLink and Linksys), as my experience of routers is that they all have some difficulties regarding communication with other devices.

Two routers were occasionally able to connect with the Profilux from an outside connection. One were not able to get contact at all. Have tried every possible setting in the routers, but it just won`t work.
If someone has a Wireless router which allows to connect with the Profilux (from outside), I would be glad if you could post which router that is. So I know what to look for.

Maybe it might be better to use the LAN card in the Profilux instead of the WLAN? It shouldn`t make any difference, but I might be wrong?

Kind regards, Conny