PDA

View Full Version : Strange Happenings! Scarry!!


benf
08/02/2008, 05:52 AM
I was calibrating my pH probe this morning and for some unknown reason my MH4 light turned on around 6:45am. At 6:51am the light went back off. The status pages showed it off the whole time! Please look at my code and see if I overlooked something that may have caused it to turn on.

If Time > 12:45 Then MH1 ON
If Time > 20:15 Then MH1 OFF
If Temp > 81.0 Then MH1 OFF
Max Change 020 M Then MH1 OFF
If Time > 13:00 Then MH2 ON
If Time > 20:30 Then MH2 OFF
If Time > 13:15 Then MH3 ON
If Time > 20:45 Then MH3 OFF
If Temp > 80.5 Then MH3 OFF
Max Change 020 M Then MH3 OFF
If Time > 13:30 Then MH4 ON
If Time > 21:00 Then MH4 OFF
If Time > 07:55 Then ACT ON
If Time > 14:00 Then ACT OFF
If Time > 17:00 Then ACT ON
If Time > 22:00 Then ACT OFF
If Time > 21:50 Then DIM ON
If Time > 08:00 Then DIM OFF
If Moon 000/000 Then MON ON
If Timer DIM = ON Then MON ON
If Timer MH1 = ON Then MON OFF
If Time > 21:45 Then FUG ON
If Time > 09:30 Then FUG OFF
If Time > 00:00 Then DRT ON
If Time > 13:00 Then FAN ON
If Time > 20:30 Then FAN OFF
If Time > 00:00 Then RTN ON
If Time > 00:00 Then CHL ON
If Time > 00:00 Then COp ON
If Time > 00:00 Then CO2 ON
OSC 180/180 ON/OFF Then ZEO ON
OSC 020/120 ON/OFF Then SEO ON
OSC 001/200 ON/OFF Then ATO ON
If Temp < 78.1 Then CHL OFF
Max Change 007 M Then CHL OFF
If FeedA 000 Then WV1 OFF
If FeedA 000 Then WV2 OFF
If FeedA 000 Then WV3 OFF
If FeedA 000 Then DRT OFF
If FeedB 000 Then WV1 OFF
If FeedB 000 Then WV2 OFF
If FeedB 000 Then WV3 OFF
If Time > 00:00 Then HT1 ON
If Temp < 78.0 Then HT1 ON
If Temp > 78.0 Then HT1 OFF
If Time > 00:00 Then HT2 ON
If Temp < 78.0 Then HT2 ON
If Temp > 78.0 Then HT2 OFF
If pH < 07.69 Then CO2 OFF
If pHB1 < 06.60 Then CO2 OFF
Max Change 002 M Then CO2 OFF
If SwitchB1 CLOSED Then CHL OFF
If SwitchB1 CLOSED Then RTN OFF
If Time > 00:00 Then ALM OFF
If Temp > 82.0 Then ALM ON
If Temp < 78.0 Then ALM ON
If pH > 08.30 Then ALM ON
If pH < 07.80 Then ALM ON
If ORP > 410 Then ALM ON
If SwitchB1 CLOSED Then ALM ON
If SwitchB2 CLOSED Then ALM ON
If Timer ACT = ON Then WV1 PF1
If Timer ACT = ON Then WV2 PF1
If Timer ACT = ON Then WV3 PF1
Pmp MODE sD for PF1
Pmp Int 030/085 for PF1
Pmp OSC 05/13/00 for PF1
If Timer ACT = OFF Then WV1 PF2
If Timer ACT = OFF Then WV2 PF2
If Timer ACT = OFF Then WV3 PF2
Pmp MODE sD for PF2
Pmp Int 030/065 for PF2
Pmp OSC 04/08/00 for PF2
If Timer MH2 = ON Then WV1 PF3
If Timer MH2 = ON Then WV2 PF3
If Timer MH2 = ON Then WV3 PF3
Pmp MODE sD for PF3
Pmp Int 030/100 for PF3
Pmp OSC 07/12/00 for PF3

MH1$-A01
MH2$-A02
MH3$-A03
MH4$-D12
SEO#-A04
MON$-D04
ACT$-B10
FUG$-B13
ATO#-B15
ZEO$-D11
DIM%-E12
DRT$-D10
FAN%-D14
RTN#-B12
WV1#-E01
WV2#-E02
WV3#-E03
CHL%-B16
HT1$-D13
HT2$-D16
COp$-D15
CO2%-D09
ALM%-A09

kenargo
08/02/2008, 11:30 PM
It sounds like you had some electrical interference. The AC sends commands every 5 minutes for all timers and given the time frames you lised above it sounds like that is what happened.

benf
08/03/2008, 05:08 AM
That makes sense...weired though and why it chose just the one light is strange.

thanks

mako199
08/03/2008, 09:58 PM
I had the same thing happen with my skimmer pump . Would shut off radomly for about 5 min then come back on .