View Full Version : Seizing Maxijets

10/21/2009, 06:40 AM
I just bought two MaxiJet 1200s in early August. One was in my 125ga, the other my 55ga. They were running w/out any issues until (of course) I went on vacation. When I got back the one in the 55ga was not functioning. I took it out, cleaned it, took it apart, checked the impeller, and there was nothing visably wrong. I tried it in the 125ga and the 55ga but it was completely dead.

I took the other maxi out of the 125 and put it in the 55ga. The next morning it was also dead! Same thing, took it apart and cleaned it, but it's just totally dead. It's plugged into a surge protector that I've had forever, it's clean and free of salt and debris and has never been wet or anything. Every other piece of equipment is plugged into this surge protector and they're working fine. Each maxi jet was plugged in a different outlet in the surge protector. I tried a cheap Wal Mart powerhead last night on the surge protector and as of this morning, it's just fine.

Anyone have any ideas?! I'm irritated I just killed two MaxiJets and I have no idea how I managed it! Thanks!