PDA

View Full Version : Belkin router blocking port 80?


ReefWaters
12/22/2009, 08:34 AM
I just had my 3rd Linksys router die on me so I went with a new Belkin this time. I have it all set up and working on my local network. I can access my ACIII Pro locally and through AquaNotes. But I cant access it through my DynDns host address or directly through my internet IP.

I went through most of the troubleshooting steps on DynDns.com. I ran their "Open Port Tool" and it came back with this.

"An attempted connection to 71.XXX.XX.XX:80 timed out. This typically indicates that traffic to that port is being actively blocked by either a firewall or your ISP."

I know its not my ISP. I had no problems getting to port 80 on my Linksys. So I'm thinking the Belkin is blocking it. Has anyone else had this problem? Is there a common router setting on the router configuration that I can undo to stop blocking port 80 or is my only solution to route the ACIII Pro through another port?

baondayko
12/22/2009, 08:56 AM
Since port 80 is the mostly widely default use port, and most people don't know it, but hackers do, I would recommend you select a different port and then give the router permission to have it opened.

ThurlowR
12/22/2009, 09:20 AM
Most ISPs block port 80 so I would go with another port also

kenargo
12/22/2009, 09:43 AM
Some routers support external configuration through port 80; is it possible you have this enabled?

I would doubt that the router is blocking the port unless there is a setting to unblock it (aka; it is blocked by default). I'd suspect something else first.

RussM
12/22/2009, 09:44 AM
Did you create the applicable port forwarding rule on the Belkin?

trd47
01/01/2010, 12:55 PM
Did you create the applicable port forwarding rule on the Belkin?

What's this? I've had my ac3 for a while now and I can't get it to connect. All I get is a message saying "page can not be displayed" WTH?!?!

RussM
01/01/2010, 01:09 PM
TRD, please elaborate. You cannot connect to your AC3 at all? You can connect while at home, but not from anywhere else?

A port forwarding rule is a configuration parameter in the router that permits traffic originating from somewhere on the Internet to be passed through to a networked computerd or other device on the protected side of the router/firewall, i.e. your home network.

ReefWaters
01/03/2010, 02:32 PM
I cant seem to find any settings that would be blocking port 80 other than this

<TABLE width=600><TBODY><TR><TD class=head_bold height="100%" vAlign=top width="99%">"Firewall > DMZ <!--p> Virtual Servers</p--></TD></TR><TR><TD><TABLE class=copy_1 width=600><TBODY><TR><TD class=body height=17>
The DMZ feature allows you to specify one computer on your network to be placed outside of the NAT firewall. This may be necessary if the NAT feature is causing problems with an application such as a game or video conferencing application. Use this feature on a temporary basis.The computer in the DMZ is not protected from hacker attacks.To put a computer in the DMZ, enter the last digits of its IP address in the field below and select "Enable". Click"Apply Changes"for the change to take effect."

</TD></TR></TBODY></TABLE>Should I put the ACIII Pro on this permanently? If not, what is a safe port to put the ACIII Pro on so I can bypass port 80?</TD></TR></TBODY></TABLE>

kenargo
01/03/2010, 05:01 PM
DMZ is a special facility in routers that allow you to place 1 device as if it was directly connected to the internet (all ports from the 1 device). IMO; I would not do this.

I still do not believe that the router is blocking port 80 unless there is some setting that is enabled by default to block it. Are you sure remote admin isn't enabled on the router or that the port forward is incorrect (an incorrect port forward would also time out for a connection)?

ReefWaters
01/03/2010, 06:56 PM
I double checked and remote admin is not enabled.

I have attached a screen shot of my port forwarding page. I dont see anytning wrong but then again, I dont know what Im doing! :lol2:

kenargo
01/03/2010, 09:42 PM
Does it work internally (http://192.168.2.50)?

ReefWaters
01/04/2010, 02:24 PM
Does it work internally (http://192.168.2.50)?


Like a Champ!!!.

AquaNotes works great too....

tamu
01/04/2010, 02:36 PM
How about changing your inbound port to something else for testing. Maybe try 7000


Then try and access it via http://whateveryourpublicipis:7000


Also, are you testing this from the outside or trying with a computer from within your network?

ReefWaters
01/06/2010, 05:57 PM
I don't know anymore. I didn't have any problems with my Linksys.

I changed the port to 82. Nothing. The "Open Port Tool" on DynDNS.com is still timing out.

I turned off the firewall on the router just to see if that was it. Nothing. Still timing out. Don't worry... I turned it back on.

I even tried the DMZ setting and that didn't work either.

I feel like I have looked at every other setting. I know its going to be something stupid that I forgot to do but I feel like Ive done everything I was supposed to.

Is anyone else running a Belkin? I should probably just call Belkin directly.

tamu
01/06/2010, 06:31 PM
Have you tried a reboot of the router?
Obviously the stateful packet inspection is working on your firewall. You are able to surf the web.

Did you try creating a completely separate rule on that page. Try a port greater than 1024.

Also, did you verify that the Dyndns tool had your correct public IP?

One more thing. In your Belkin router, on the status page what does your WAN or public IP show? is it a private or public address? Are you using DSL?

tamu
01/06/2010, 08:09 PM
The other times I have seen this is when a DSL modem is not in bridge mode and is NATing/firewalling the addresses when they come in and then handing them off to the router which in turn NATs/firewalls the addresses again.

So, even though you open up ports or turn the firewall off on your router, the DSL modem/router is still blocking all unwelcomed requests.

In this scenario your web surfing would be perfectly normal.

This is the only thing that I can think of. The give-away will be your WAN IP on the Belkin.