PDA

View Full Version : DI filter gone bad already?


SF2K4
07/31/2010, 07:46 PM
I've barely done 30 gallons of water with my mighty mite RO/DI. I have a dual TDS meter and the ppm reading before the DI has stayed the same. Post-DI today was 16ppm. Four days ago it was 4ppm. Until then it had been 0. Anyone know what could be going on?

mullinsd2
07/31/2010, 07:48 PM
At first i was thinking your di resin was leaking through, but you said it was working fie before hand; therefore, you may need to check your water pressure. If you do not have your pressure up, then you di resin will not work correctly if I am not mistaken. Can you check your pressure? I think this is my problem too.

SF2K4
07/31/2010, 07:49 PM
I've been putting the faucet on full-throttle and on barely a dribble. No matter where I put it I get about 16ppm now. This ****es me off 'cause I thought DI filters were supposed to last the longest out of all the filters.

JAustin
07/31/2010, 08:05 PM
no, DI goes quicker than any other filter. My TDS on incoming water is over 400ppm. My membrane knocks that down to 24 and the DI takes care of the rest. I get about 120-150g of 0ppm water before the DI is done.

Yours should not be done after 30g though, maybe bad DI. Order new DI from BRS of somewhere and try that out. What's your incoming water TDS?

maynardjames
07/31/2010, 08:30 PM
are you on well water. i am & have high c02. go thru di resin like crazy to the point where im going to stop buying. i have a dual di unit & wipe out both sides making 100 gallons of water.in my search for answers high c02 was what i came up with from many different sources