PDA

View Full Version : APEX Firmware Update Problem


pjgriffin
09/05/2010, 09:20 PM
I am trying to update my APEX to the latest firmware (currently 4.02). I have an XP computer connected to a router with APEX unit connected. XP computer can access the APEX directly and has previously been used for updates.

The update software finds the APEX, reports successful login then tries to connect and repeatedly says "timeout, APEX failed to respond".

I have connected a Windows 7 laptop directly to the APEX module. I can ping APEX but on running the update I receive the same timeout message.

Any suggestions for steps that I have forgotten since my last update.

Thanks

Peter

milkman55
09/05/2010, 09:37 PM
If you download the users guide in the first sticky of this forum, you will find at the top of page 86 instructions on forcing the Apex into bootloader mode. Basically, you start the update and while it is trying to locate the base unit, you unplug the power and then plug it back in which forces the Apex into bootloader mode.

pjgriffin
09/06/2010, 09:06 AM
Thank. I tried to power cycle with either computer connected and in both cases the APEX controller started normally and the computer continued in the timeout cycle. I will send an email to Neptune.

Peter

kenargo
09/06/2010, 10:20 AM
Power cycle the Apex 'after' the uploader starts counting connection fail attempts. During the time the Apex status LED should be flashing; an indication it is running in boot loader mode.

pjgriffin
09/06/2010, 12:12 PM
Tried that a few times. The APEX flashses yellow a few times then switches to green but the loader stays in the timeout loop and software is not updated.

I have reloaded latest version of Net Framework and checked to insure no other network addresses are present.

Sent an email to Curt.

CalmSeasQuest
09/06/2010, 03:04 PM
I have the same issue. Mine is resolved but rebooting in the safe mode, then processing the update.

pjgriffin
09/08/2010, 06:32 PM
Thanks for the advice from Curt and others. Running Windows XP in safe mode allowed the up[grade to proceed smoothly.