PDA

View Full Version : questionable service


critteral
10/01/2010, 06:40 PM
I have been buying systems and refills from Jim for several years and this was the first problem I have ever had with them. In the past, they have been great. However I bought a booster pump from them about 2 years ago and it went out. I called Jim and ordered a replacement pump and it started to leak within 3 weeks. I called Jim expecting a replacement pump with no problem. I expected him to say, send it back and I will send another. But thats not what happened. Jim told me that they don't go out like that and I must have bad water? come on! He told me I would have to call the manufacturer and see if they would take care of it because it was out of his hands. 3 calls to the manufacturer's no customer service line have gone unanswered. All I get is a recording. Now I have a pump that leaks 30 gallons a week from the upper seals and no one will help me.

Look elsewhere for booster pumps if you need one for Jim's system, you get get no help from him if you get a bad pump :furious:

Thefilterguys
10/06/2010, 12:44 PM
Sorry your unhappy but Aquatec takes care of repair or replacement of their pumps. There is a reason your two pumps have failed by the gasket leaking and they are going to be best at resolving the issue. Sending you a third pump is only going to end in another failure so you need to have the pump manufacturer resolve the issue. I do suspect it has something to do with your water quality or pH which may be acid.

Jim

The delay in answering your post is due to an ongoing sever problem.

critteral
11/05/2010, 06:44 PM
three vm left with customer no service at Aquatec in 6 weeks with no return call. Great company!! :furious::furious:

Thefilterguys
11/08/2010, 11:25 AM
I have a call into Aquatec give me your phone number by PM and I'll see if I can get you connected.

Jim

Thefilterguys
11/10/2010, 11:41 AM
Ok I found out it is a matter of calling the correct number at Aquatec. PM me your name and address and pump model number, serial number, and manufacture date from the label. I will get you an RMA from Aquatec, with direct attention of the engineer to see what is wrong.

Jim

Thefilterguys
11/11/2010, 11:09 AM
After talking with Aquatec I dismissed this but is it possible the pump is leaking around the gray inlet or outlet port or where the tubing goes into the 3/8 x 1/4 reducer fitting which is in those ports. Have you looked closely to see exactly where the leak is coming from?

Jim

critteral
11/21/2010, 07:34 AM
PM sent

Thefilterguys
11/22/2010, 09:39 AM
I am here to guide you through the process of getting this taken care of by Aquatec. All I need now is the manufacture Date off the label and I'll get you an RMA. In talking to them your leak is unusual and they would like to get their hands on your pump.

Jim

critteral
11/23/2010, 09:48 AM
if you need anything else, let me know.

Thefilterguys
12/02/2010, 03:07 PM
Sorry for the holiday delay. Your RMA from Aquatec has been sent and it's up to you to get the pump returned to them for repair or replacement.

Jim