PDA

View Full Version : Sunpower Ballast replacement


kellerexpress
04/02/2011, 04:13 PM
I recently had a ballast go bad in my 6x39 ati sunpower. Bulbs 4 and 6 won't fire. Only had the fixture up and running a month. Reefgeek sent me a replacement ballast and I was wondering if anyone had some pictures or some instructions about how to replace a ballast on one of these fixtures? Thanks

kellerexpress
04/02/2011, 11:53 PM
Ttt

kellerexpress
04/03/2011, 03:43 PM
No one has replaced one of these?

Herbie
04/03/2011, 07:27 PM
Just did one on my 1 month old Sunpower 6 x 24. It was a piece of cake. LOTS of small allen head METRIC screws. They are all the same size, I just cant remember what it was, but it was small! It should have come with directions ???
Anyway, UNPLUG IT FIRST !!! Remove the bulbs and shield. Remove the fans and wires ( note the colors). Take all the end cap screws off on both sides. There are 2 screws in the center that hold the internal assy. to the outside alum cover. Pry off the cover, its kind of wraped around the ouside reflectors........careful everything is razor sharp. Pull off the cord bezel, and remove the alum cover to expose the internals. The ballasts are going to be right in front of you. It should be easy to figure out the 4/6 ballst as it should have a seperate power supply. But follow the wires from the 4/6 sockets, they will lead you to the bad ballast. The wires are quick disconnect and only require a very small pick to put pressure on the retainer clip. Push the clip, and remove the wire.......... x 6 if I remember. Note the wire colors and reassemble the same way you took it apart.
Just reverse it all to reassemble. It really pretty easy. Just take your time, and make sure you get the wires back the same way they were before you touched it. Make a diagram, it may help if you are unsure during reassembly.
It took me approx 20 minutes. No big deal.

Check your bulbs when you get it back together. When my ballast went out, it took out 2 bulbs with it. They were VERY dim after the ballast went bad. I was sent 2 new bulbs with the ballast, and everything is fine now.

Good Luck........
Herbie

kellerexpress
04/03/2011, 08:40 PM
Thanks so much for the info, I couldn't find instructions anywhere and reefgeek forgot to include some. I'll take a stab at it tomorrow. Again, thanks!