PDA

View Full Version : LTA Nem Issues and Pics


Spydermonky
01/26/2012, 09:02 PM
I originally posted because my Nem wasn't grabbing onto anything. Well, I am concerned now that there is something wrong as he hasn't moved. I put a long list of my param's etc here http://www.reefcentral.com/forums/showthread.php?t=2123315 Here are the pics. He just sits as in the last pic, and has been there since the first night. I have tried to right him a couple times. From those of you who know, does he look ok?

Spydermonky
01/27/2012, 08:45 AM
This morning he was upright, but still not holding onto anything. I understand it can take a while for them to find a good spot, i'm just concerned he has other issues as he is not even attempting to.

BairdimusPrime
01/27/2012, 10:12 AM
I'm a bta guy myself but with all nems its best to leave them alone the first 48 hrs and see where they move themselves...my brother in law has a large LTA it stays in the sand at the bottom of his tank it took him almost a week to find its spot though...
colors look good try to get a shot of its mouth for us and best of luck

Spydermonky
01/27/2012, 10:32 AM
Thanks, I really appreciate the feed back. Here are some pics of the mouth from this morning. He was upright, but his foot was not attached.

Matt1351
01/27/2012, 10:41 AM
If you can just leave him be. When I add anemones I try to set them in the back of my tank and let them move where they want.

homegrownREEFER
01/27/2012, 10:48 AM
Yeah, like I said in your other thread, mine took almost 3 weeks to foot itself. You say you got it from the LFS, are you sure it is a LTA? It is kind of hard to tell from your pictures since the blue is washing everything out, but a look from the underside would let you know for sure.