PDA

View Full Version : Breakdown # 2 for Vortex MP40 after year.


pjewett
02/11/2012, 12:28 PM
Geez. I love this thing but first the powersupply goes and I have to replace it. Now the wetside has come apart in two pieces causing the outside housing of the wetside to rotate and spin off.

I can't seem to see how they snap back together and nothing looks broken.

Do I need to replace it or am I missing something?

Thanks in advance.

:angryfire:

RussM
02/11/2012, 12:35 PM
Sounds like you are talking about a Vortech. Did you mean to post in the Ecotech forum?

pjewett
02/11/2012, 12:40 PM
woops, yep.

TruReef
02/11/2012, 12:48 PM
look on the ecotech website for cleaning instructions as well as disassemble and reassemble instructions. The wet side has a groove in it that you place the cage into and turn.

pjewett
02/11/2012, 01:01 PM
This is what it's doing...

http://youtu.be/22QQhSiD_WM

TruReef
02/11/2012, 01:05 PM
WOW, never saw anything like that from mine.. hopefully someone else can chime in... Mods can this be moved to the EcoTech forum for more help???

L8ndeb
02/11/2012, 02:17 PM
That thing needs to be broken down and cleaned. Looks as though the magnet and housing are fused somehow. Hope there has been no damage done.

aquamanic
02/11/2012, 05:26 PM
Look at your magnet and see if it split and swelled up. Mine did something very similar to what yours is doing and it was the magnet that separated. Looks like they're made in layers with an epoxy over them.

fio1022
02/13/2012, 07:02 AM
That looks like its drilling through the tank.

MTWiley
02/13/2012, 01:07 PM
Wow, looks interesting, I've never seen anything like that before.

kenghmoob
02/15/2012, 06:24 PM
That looks crazy. Hopefully you get that fixed. Good luck