View Full Version : Repeated failure while flashing to 4.20-CA12

12/26/2012, 12:17 PM
With some holiday time to spare, I decided to try and upgrade my Apex to the latest beta version as I really like (and want!) that snazzy new UI. Using the upgrade tools provided, I've been unsuccessful so far and hoping one of our Apex experts can help.

Using the ApexFlash utility for mac, the utility seems to find my controller, asks for the login and password, and then proceeds to try and update. It will eventually get to the "Unlocking controller" phase and just begins cycling through "failed unlock attempt" messages (see attached for screenie).

Some relevant details:
- Trying to upgrade to version 4.20-CA12 of the firmware and web pages
- Both my pc and apex are on the same physical and logical network and are segmented only by my network switch
- I can access my Apex at it's local address with no problem using any web browser on the local network including the PC I'm trying to upgrade from
- I can telnet into my Apex at it's local address
- The controller display does nothing other than show the normal status display when I attempt to update (not sure if it should show anything different during the update process)
- I tried powering down the Apex and then running the update after it had restarted. No luck
- I tried powering down the Apex and then running the update WHILE it was restarting. No luck
- PC firewall and AV are both off. No firewall exists between my pc and the Apex.

I'm at a loss for what to try next so hoping one of our experienced Apex folks can provide some guidance. Thanks!

12/26/2012, 12:25 PM
You sir... have the same problem as I do... Or at least on the surface you do.

I cant do anything with my Apex at the moment though... and its stuck in bootloader mode (blinking yellow light).

I'll be interested to see how you fix your issue.

12/26/2012, 12:34 PM
I'm having the same issue this morning. Am at a complete loss on how to recover.

12/26/2012, 12:37 PM
snarkes - saw your other "Ugh" thread and very sorry for you. In my case I guess it is "good" that my controller never started taking the update...particularly if there's an abnormal chance of bricking the controller.

So far, my controller is rolling right along and has ignored all my attempts to update it. I guess I can call it "very stable" from a performance point of view.

I've done only one other firmware update not too long after purchasing and installing the controller and that one went through without a hitch. I'm not sure what it's trying when it displays "Unlocking controller" and not sure how to help it along with this update.

12/26/2012, 12:48 PM
You say they are on the same physical network. Does that mean they are both hard wired into the router\switch?

12/26/2012, 12:59 PM
HV1990 - Yes, both the controller and the pc I'm updating from are on the same physical network (controller<-->switch<-->pc).

In my case, they are also on the same logical network. The switch is a managed, configurable switch. Both ports are handling untagged traffic on the same VLAN. Both devices share a common subnet. No intentional filtering happening in between. Short of hooking up an inline packet sniffer to watch for anything unusual, the network has been tested pretty thoroughly.

I'm going to borrow an unmanaged 4 port switch this evening and see if that makes any difference. Will update when I do.

While I'm certainly not above making an error in the networking, it's what I do for a living so I've tried to rule out any issues there. If it was a networking issue, I'd be glad that it was something I could work directly.

12/26/2012, 07:00 PM
bkronwing: I doubt a different switch will make a difference. If Apex and Mac are in the same VLAN, there's no .1Q tagging happening, and there should be absolutely no difference in how the packets are processed / switched. I'd be quite surprised if you found that an unmanaged switch allowed the update to proceed properly. (I'm a network geek too ;) )

Do you have a BootCamp or Parallels/Fusion/VirtualBox setup? or a Windows notebook you can try?

I'm going to PM you with something else I want you to try.

12/27/2012, 08:22 AM
Just tried swapping out the current network switch for something simpler (an unmanaged 4 port netgear switch). Confirmed that the networking was working as expected. Web page displays and telnet to the controller are working like a champ.

So, tried the update utility again and get the exact same results as before. Sigh...was really hoping that it was something funky in my switch.

Next step is to try from Windows 7 pc instead of my Mac.

12/27/2012, 08:30 AM
RussM - thanks for the willingness to help. Much appreciated. Tried your suggestion and the controller performs the process but there is no change to the versioning information. Both lines are the exact same before and after:
Copyright 1996-2011 - Neptune Systems - Rev 4.12 - 5A12
Just to be thorough, I did it from both Windows and Mac pcs with the exact same results.

I have also now tried the Update utility from both a Mac and a Windows 7 pc. Still get the same type of error message (the message itself is a bit different on the Windows application but it goes through the same connection attempts and then timeout).

Thanks to all for the help. Good to see some others are getting their update issues resolved and hoping that we'll find the combination to make mine work. Willing to try / re-try anything so let me know if you have any ideas.

12/27/2012, 09:35 AM
Someone else here had luck with this running windows in safe mode with networking. Give that a try.

12/28/2012, 05:39 PM
I did try it with a Win7 pc booted into safe mode with networking. Received the same error as before and as noted above.

Really not sure what to try next so if anyone has a suggestion, I'm ready to try it.