PDA

View Full Version : IPhone App Connection Issue


milkman55
04/13/2013, 10:21 AM
I have had my iPhone connected to my Apex for sometime, but since the last app upgrade and / or Apex firmware upgrade, I can only access my Apex from my iPhone and iPad when I am on my home network.

I use DYN Updater for the external address and have IP 192.168.1.50 assigned to the Apex with port 80. This has been working for a long time and I can still hit the Apex from my iPhone / iPad web browser using the web address assigned by DYN Updater and also keying in the hard coded IP address works. Its just the app that will not connect unless I am on my home network. I am entering the above IP address and port 80 on the app configuration screen. For display name I have tried everything, but not sure that matters?

Any ideas?

milkman55
04/15/2013, 10:22 AM
Bump for the weekday crowd. I can call Neptune if I can't get a response.

slief
04/15/2013, 06:00 PM
The IP address (192.168.1.50) is your internal network address for your Apex. That will not work from anything other than your internal network.

You should instead be using soemthing like: yourname.homeip.net
Or whatever virtual name you chose from DynDns.
On your DSL router, you need to make sure that port forwarding is set to the IP address of your Apex which I would assume the 192.168.1.50

Again though, regardless of your dynDns settings, your Apex app will not work to connect to your apex from outside your home network or over 3G using the IP address you provided. All DynDns does is provide you with an app for your home computer that updates DynDns servers if your DSL routers gateway address changes and DynDns also gives you a url such as that I mentioned above to connect to your internal device.

My Apex app is set to my***.homeip.net
I have my Apex setup as a webserver on my DSL router which forwards to port:80.

Again, make sure port forwarding is setup on your DSL router and the Apex IP address is setup in the router for port forwarding.

Make sure you are using your DynDns virtual address in your app such as yourname.homeip.net (not 192.168.1.50)

You can test the remote access simply by opening up a web browser on a computer or device not on your local network and typing in that virtual address. If you have your router setup properly, that should open the Apex web interface just like you were at home at which point you will be prompted for your username and password. If that works, the iPhone App should as well. If that works but the iphone app wont, I would suggest deleting the app and reinstalling it on your phone.

If you can get your gateway address of the DSL router, you should be able to connect to that IP with:80 at the end but realize that DSL gateway IP address's usually change everytime they are power cycled or rebooted. Thus the need for DynDns.

milkman55
04/15/2013, 09:00 PM
Thanks, will give it a shot again. I have no issue hitting the Apex using the DYNdns virtual address from a web browser outside my home network. I will try deleting the app and reinstalling as I already tried putting the virtual address in the app settings.

milkman55
04/17/2013, 02:53 PM
I can't believe it took me this long to figure this out, but it was simple, as usual.

I was putting the http:// in front of my public address supported by DYN Updater. I just dropped the http:// and it worked.

Amazing, I know my app worked for a long time before the last upgrade. At least I am back in business when not on my home network.