PDA

View Full Version : Did Micro Power Outage Fry MH Ballast?


Buzz1329
08/25/2013, 12:30 PM
I had a seconds long power outage in my house yesterday. One of my metal halide lights was on at the time (controlled by a RKL). Stupidly, I had forgotten to program the RKL to keep the MH off for 15 minutes after the power outage. Now, I can't get that metal halide to turn on whether it is connected to the RKL or not.

Am I SOL on the ballast?

Thanks.

degibson84
08/25/2013, 12:45 PM
I used to turn mine off and on with no issues. I thought that it was just the bulbs that needed to warm back up. try the ballast on another bulb and see if it fires that one up to make sure it isn't the bulb

Buzz1329
08/25/2013, 03:26 PM
I used to turn mine off and on with no issues. I thought that it was just the bulbs that needed to warm back up. try the ballast on another bulb and see if it fires that one up to make sure it isn't the bulb

Thanks. I'll try that, although the bulb is only 3 months old.

degibson84
08/25/2013, 04:52 PM
Well the bulb could have went when the ballast tried refiring the bulb

Buzz1329
08/25/2013, 05:05 PM
Oh. You're right. I'll try a new bulb tomorrow morning.

Thanks again,

degibson84
08/27/2013, 12:56 PM
did you figure out the bulb situation?

Buzz1329
08/27/2013, 08:37 PM
did you figure out the bulb situation?

You were right. It was the bulb (a Hamilton 400 watt 20k SE bulb) not the ballast. I wasn't thrilled with the Hamilton color, so I swapped out all three bulbs for their XM counterparts and also replaced a Purple PLus T5 bulb with a Royal Blue Actinic T5.

I love the Hamilton Cebu fixture, but it weighs a ton, and getting it off the tank to change the bulbs is a chore.

Anyways, thanks again for the help.

degibson84
08/28/2013, 01:44 PM
thats good it wasn't a ballast. if you ever have an issue with the ballasts i have 3 400W blueline ballasts from a 300 gallon takedown

Buzz1329
08/28/2013, 03:05 PM
Thanks. I'll definitely keep that in mind.