PDA

View Full Version : Vertex Libra Dosing Pump Issue


jrb466
04/21/2014, 09:02 AM
Does anyone have experience with the libra dosing pump? I have set up automatic dosing twice. Both times after a week or so the touch screen become unresponsive.

Unplug and plug it back in now it works again but I'm not confident that it won't happen again so I quick dose every night. Kind of defeats the purpose of having a sexy expensive dosing pump. I was running BRS 1.1 ml pumps with the apex and really missing them at this point. Is anyone else experiencing issues with the Libra?

Relativity
04/21/2014, 01:32 PM
Did you download the firmware update from the vertex site

jrb466
04/21/2014, 01:39 PM
Yes the firmware (Libra_FW_394) dated 1/16/14.

puks
05/23/2014, 11:10 AM
The same issue but statistics shows it worked. Looks like only display is non-responsible.

puks
05/23/2014, 11:29 AM
Is the Libra connected to Apex?

jrb466
05/23/2014, 12:21 PM
I don't believe you can connect the Libra to the Apex. Unless you are just talking about power for the Libra.

I'm switching back to the BRS dosing pumps and dumping the Libra. I had higher expectations for the $$$.

puks
05/23/2014, 12:36 PM
Yes, I meant Power connection