PDA

View Full Version : litermeter III water changer help


rogergolf66
08/08/2014, 07:21 PM
ok so I have had this sitting around for a bit 6 months and haven't set it up. I finally got around to setting it up. I ordered new hoses. It was working before. after changing the hoses

1. I can't get the main pump to turn the rollers :( the post turns but it doesn't turn the rollers.
tried to add Vaseline on the tube as BRS recommended. didn't work.

what should I try next?

2. now when I plug in the second pump into B or C plug the light that lights up on the unit is the only plug I'm not plugged into. also when I try to do a on test on that pump nothing happens. but if I select to turn on pump A and plug the stand alone pump into A the built in pump turns off and the external pump turns on. the external pump is able to turn the rollers when I do this. only when plugged into A.

what can I do? I really don't want to buy another unit. can these be sent In for service? if so how much does that cost?

step 1 I have to get the main unit to read the second pump in B or C. if I can't there is no need to get the internal pump to turn the rollers.

Roger

SpectraPure
08/08/2014, 07:47 PM
Step 1 will be to get some ACETONE and remove any trace of grease. Shaft,
rollers, tubing - all squeaky-clean.

Clean both pump heads and put them back together. If you can get one pump
to run and one doesn't, swap the head assemblies and see which part the
problem stays with.

There is a priority to activating the pumps. Only one can run at a time. If A is on, then B and C won't run. If B is on, then C won't run. Other than that, I am not familiar with the symptoms you describe.

Scott @ SpectraPure

rogergolf66
08/08/2014, 08:21 PM
I already cleaned them. I used alcohol wipes.

I am not trying to run 2 pumps at 1 time. I am saying if I plug a pump into b or c and I turn on b or c it dosnt turn on that pump. But I know that pump works cause if I plug the same pump into a it works.

I also already tried swapping heads and parts to get the internal pump to turn the rollers no luck but again the metal shift turns fine

Do u service these If I sent it back to u? If so how much?

SpectraPure
08/08/2014, 08:29 PM
OK. We will have to look at them - both units. There is a 5-year warranty
with proof of purchase.

Scott

rogergolf66
08/08/2014, 08:53 PM
Where do I send them and addressed to who? I would need a price before work is done as a new main unit is near $250 now

SpectraPure
08/11/2014, 10:58 AM
Please contact our technical service for an RMA and cost estimate (if required).
bruce