PDA

View Full Version : Aquatec Booster pump added-no increase :-(


SouthFla
09/29/2015, 05:54 AM
I wonder if you might be able to help-while this is probably an Aquatec issue it's plumbed to my Spectrapure unit. I just added a new Aquatec 8800 booster to my RODI but I am not seeing much increase in pressure. The pump is plumbed after the .5 sediment and .5 carbon, and before the SpectraSelect Plus 90GPD and Silicabuster DI. My water pressure from my hose bibb (4' away via 1/4" tubing) is 36psi, and with the pump on pressure only increases to 40psi. I can hear/feel the pump running.

I tried removing the pump from the RODI and plumbing the raw water directly in to the pump and measuring the pressure directly exiting the pump, but still only see the 40psi. Adjusting the pressure screw clockwise on the pump did not increase the pressure.

Any thoughts or troubleshooting tips, or did I maybe just get a bad pump? I'm still waiting to hear back from Aquatec...Thanks!

John

SouthFla
09/29/2015, 02:34 PM
Nevermind, problem solved working great now :fun2:

SpectraPure
09/29/2015, 04:33 PM
im curious as to what your fix was. I was thinking that they pump was backwards, or a flush valve was open.

Jeremy