PDA

View Full Version : Everytime I update/refresh, my water gets worse and worse...


dburt520
12/21/2015, 12:08 AM
I am using a 90GPD CSPDI RODI system - When it was brand new, out of the box (3 years ago now) it was flawless, 100% 0 TDS water.

I have changed filters out several times, and each time it takes longer and longer to get to 0 TDS.

I recently replaced the RO membrane for the first time (with the 99% rejection membrane - my pressure was always 75-80), fresh filter, carbon, DI and I added a second 99% rejection membrane piggy back kit.

I ran the system all day and I can't get the TDS to fall below 003 on the OUT. The instructions for the Piggyback add on were extremely poor, however with a little time and youtube it was relatively easy to figure out.

Do you guys offer a "refurbish" service. I am local, I can drop my system off - it would be great to have someone go through it and see what I am missing.

Thanks
Dave

SpectraPure
12/21/2015, 04:59 PM
Dave,

We spoke on the phone right?

Jeremy

dburt520
12/21/2015, 11:10 PM
Yes sir, that was me. See you Wednesday!

Dave

SpectraPure
01/04/2016, 11:10 AM
Dave did you come in on Wednesday? I do not recall.

Jeremy

dburt520
01/04/2016, 05:41 PM
Hi Jeremy,

I did but you were out of the office. I figured I would wait until after the holidays and come back by.

What day this week works for you?

SpectraPure
01/05/2016, 01:24 PM
When are you thinking?

Jeremy

dburt520
03/30/2016, 01:02 PM
Jeremy,

I did not forget about this... been in between tanks so I have not used my system at all.

Are you available this week if I came by? The time is getting closer to fill my new tank, so I want to make sure my RODI systems is working correctly before i start making water for it.

Thanks
Dave

SpectraPure
03/30/2016, 03:23 PM
Friday will work for my Dave.

Jeremy

dburt520
03/30/2016, 03:54 PM
Perfect, say noon?

SpectraPure
04/01/2016, 12:35 PM
If I am not here talk to JR.

Jeremy