PDA

View Full Version : Very Noisy ASOV


erndog1001
01/15/2016, 11:00 AM
Hi I've got a Typhoon III Extreme RO/DI unit that I bought at my LFS about 2 1/2 years ago now .
It bought it completely assembled and it has and is doing an awesome job. With one exception. Id say a little over a year or so ago the ASOV started to make this horrendous loud noise.
Here is what triggers it. I have 2-75 gal holding tanks with floats valves to shut off the RO/DI inbound lines. This obviously causes the ASOV to engage and cut off the water.
Then what I guess happens from time to time is that from evaporation the float valve(s) open just slightly and allow just a tiny bit of water to pass.
The back pressure to the ASOV then obviously weakens and this is when this very loud noise starts. It starts quietly and then builds in volume until you can literally hear it from just about anyplace( the unit is in the basement) in the house. The duration and volume varies But trust me when I say that it is always pretty loud.
I brought it up one day at the place and I bought it and he gave me a used ASOV that he had lying around. This cured the problem for a while But now in the last couple weeks its back.
I should mention that Im on city water which just happens to be some of the purest in the USA
Are these valves just shot? Or is there something I can do to remedy the situation.
Sorry for the length of this But it was necessary to explain it fully

bc1281
01/30/2016, 10:58 AM
This has happened to me a few times, and each time thinking the valve was a dud. It wasn't until I replaced my back flow preventer that it stopped. I'm still not sure what the problem was, but that worked for me.