PDA

View Full Version : Problem with Red Dragon 1500 Pump


echoreef
05/06/2016, 10:33 AM
I need help to understand what the problem is with my skimmer pump and the parts I need to get it working again. I have a used Vertex Alpha 250 skimmer with the Red Dragon 1500 mini-bubble king pump. The pump is no longer working. I have took it apart and soaked in vinegar overnight but no success. When I plug in the pump, it would make a buzzing sound then shutoff. The impeller is not spinning.

So after going to this forum to do my research and reading the Red Dragon 1500 pump maintenance manual, I suspect that my problem is due to the motor block. If that is the case, it would be easy enough to just order a new motor block. However I have some concerns. The carbon bearing is attached to the magnet at the end of the impeller and I cannot remove it. Plus this carbon bearing looks nothing like the one on the pictures in the manual or the royalexclusiv.com website. I tried to yank out the bearing from the impeller with a pair of pliers but it won't budge. Is it permanently attached? I am wondering if I have an older model that is build differently and require different parts. Not sure where to go at this point since my skimmer hasn't worked in a week.

echoreef
05/06/2016, 10:42 AM
Pictures of impeller and bearing.

http://uploads.tapatalk-cdn.com/20160506/806555089ea50679a28e0ef04606fd8a.jpg

http://uploads.tapatalk-cdn.com/20160506/2db0d9894b109375d02ead6501fbe00a.jpg

http://uploads.tapatalk-cdn.com/20160506/cca5074255474199c13a80b8fd5fd997.jpg

slief
05/06/2016, 01:25 PM
Pictures of impeller and bearing.

http://uploads.tapatalk-cdn.com/20160506/806555089ea50679a28e0ef04606fd8a.jpg

http://uploads.tapatalk-cdn.com/20160506/2db0d9894b109375d02ead6501fbe00a.jpg

http://uploads.tapatalk-cdn.com/20160506/cca5074255474199c13a80b8fd5fd997.jpg

That is a standard Red Dragon 1500. Your issue is that bearing. Sticking to the shaft like that is a due to a lack of maintenance and it should never be stuck to the shaft like that. For reference on future maintenance, the pump should be taken apart and cleaned in vinegar every few months. When cleaning the pump, the bearing should be removed from the bottom of the magnet cavity and cleaned as well. You need to make sure that the hole in the center of the bearing is clean and that the end of the impeller shaft is clean and smooth. A scotchbrite pad can be used to clean the shaft end and a toothpick can be used to clean the hole in the bearing. The bearing needs to spin freely on the shaft without any resistance. If you don't clean the bearing and shaft end on a somewhat regular basis, the bearing will stick to the shaft (like you are seeing) as a result of calcification. This will cause the impeller to stop spinning and can lead to premature failure of the block. In your case, I think your block is probably ok.

In your case, not only is the bearing stuck to the shaft but the bearing also looks to be destroyed. You need to get it off the shaft first and foremost. Then you need to order a new bearing.

I would soak it some more in vinegar and try pulling the bearing off the shaft. You can try warming some vinegar up a bit as the warmer vinegar will accelerate the calcium breaking down. Otherwise, you can use a dremel tool and cut it off the shaft. Be careful not to damage the shaft or magnet when doing so. Then clean the end of the shaft with some scotchbrite and shine it up like new. When you get the new bearing, you need to insert the bearing into the magnet cavity and get it in there properly before installing the impeller shaft. There is a rubber o-ring on the bearing that holds it into a notch inside the bearing cavity at the bottom of the motorblock.

Here is a link to the new bearings.
http://royalexclusiv.com/Spare-Parts/Mini-Red-Dragon-Red-Dragon-1-BK/screws-consumables/carbon-bearing::243.html

echoreef
05/06/2016, 01:35 PM
Slief, thank you for coming through with the great support. I have a dremel but will try to use warm vinegar to get the bearing off and order a new one. If the new bearing doesn't fix it, I will get the replacement motor block. I must confess I have not cleaned the pump in over 2 years. That will change once I get my skimmer working again.

slief
05/06/2016, 01:44 PM
Slief, thank you for coming through with the great support. I have a dremel but will try to use warm vinegar to get the bearing off and order a new one. If the new bearing doesn't fix it, I will get the replacement motor block. I must confess I have not cleaned the pump in over 2 years. That will change once I get my skimmer working again.

Glad to help.. Cleaning is often overlooked. It's one of those areas that if these pumps are properly maintained, they will last 10 years or more. That happens to be a great pump and they last a long long long time if taken care of. That bearing is the one thing that is most often neglected too. Don't pry between the bearing and magnet. The magnet is bonded to the shaft and you don't want to break that bond. Worse case, we have the blocks too but based on the fact that the block tries to spin the shaft as evidenced by the noise you mentioned, I think your block will be OK.. Fingers are crossed! :thumbsup:

slief
05/06/2016, 01:50 PM
If you want to send the pump to our facility in Ft. Myers, we can fix it for you and just charge you for parts and shipping. We will test it & make sure it's all good before shipping it back to you. If you want to do that, just let us know and we will get you the address. We have all the parts needed on hand and will only charge you for the parts you need.

echoreef
05/07/2016, 02:27 PM
I am going to try out the bearing replacement first. I was able to use the dremel to cut off from the magnet last night. If this doesn't work, I will ship to your facility.

slief
05/07/2016, 03:52 PM
I am going to try out the bearing replacement first. I was able to use the dremel to cut off from the magnet last night. If this doesn't work, I will ship to your facility.

Sounds good. Make sure you clean that shaft end so it looks and feels like new.

echoreef
05/12/2016, 09:23 PM
If you want to send the pump to our facility in Ft. Myers, we can fix it for you and just charge you for parts and shipping. We will test it & make sure it's all good before shipping it back to you. If you want to do that, just let us know and we will get you the address. We have all the parts needed on hand and will only charge you for the parts you need.

I got the new bearing today. Put it in but it seems really loose against the motor block. The old bearing was super tight and I had to pull from the motor block with pliers. Pump is still not working. Can you provide me address to ship the pump to your facility? I am trying to get this out right away as I have been operating without a skimmer for a few weeks already.

ReefClownMIA
05/12/2016, 09:41 PM
I got the new bearing today. Put it in but it seems really loose against the motor block. The old bearing was super tight and I had to pull from the motor block with pliers. Pump is still not working. Can you provide me address to ship the pump to your facility? I am trying to get this out right away as I have been operating without a skimmer for a few weeks already.

PMed

TWISTER702
05/17/2016, 07:05 PM
My red dragon 1500 just died, Where can I get a replacement any one know?

slief
05/17/2016, 07:25 PM
My red dragon 1500 just died, Where can I get a replacement any one know?

What model skimmer do you have?

TWISTER702
05/17/2016, 08:02 PM
bk 250 internal.

slief
05/17/2016, 08:25 PM
bk 250 internal.

PM sent.

echoreef
05/18/2016, 10:18 AM
I ended up ordering the motor block. Will update once it arrives to see if this fixes the problem. I can't imagine anything else since the impeller is in great condition.

echoreef
05/26/2016, 12:20 PM
The new motor block arrived yesterday. Skimmer is up and running again. Thanks to the guys at Royal Exclusiv for the great customer services and great product.