PDA

View Full Version : Mr Dual


homer1475
05/08/2016, 01:18 PM
So I purchased this reactor, and for the life of me I cannot get it to tumble the GFO. Yes I have it in the GFO side and even with the shutoff completely open and the carbon side off, the water just trickles out?

I'm only using 1C of BRS GFO, with the size of the reactor it should be able to handle quite a bit more. I've tried running it with no media and it seems to work fine, but as soon as I put any media in, the flow is cut to a trickle(IE not enough flow to tumble the GFO), I would love to send this back and get a full refund, but as I had to modify the bracket(basically cut a huge chunk of it off), I doubt they'll take it back now. So I have no choice but to see if somehow I'm missing something. I did have high hopes for this reactor, but it seems as though my hopes were unfounded. I knew I should have just purchased the BRS unit.

Edit:
I have the cobalt MJ1200 pump feeding the reactor.

SpectraPure
05/09/2016, 08:43 AM
Try cleaning the screens.

Support at SpectraPure

homer1475
05/09/2016, 03:48 PM
It's brand new.

I tried without the filter pads, with the pads, heck I even removed the screens and tried just the filter pads. Nothing helped it.

SpectraPure
05/09/2016, 04:13 PM
With no carts in the chambers, does the pump move a decent amount of water through the unit and back to the sump?

Suppport

homer1475
05/09/2016, 06:41 PM
Yes it moves water just fine If there is no cartridges in the chamber. Even with the cartridge empty it doesn't push a whole lot more then a trickle. The funny part is, if I switch cartridges(carbon to gfo and vice versus) then it still slows down. Its only the GFO side. The carbon side(down through) works just fine, even if I switch the GFO cartridge to the carbon reactor.

To me, it almost looks like the cartridge doesn't fit right, almost like it doesn't allow the water up through the cartridge properly.

homer1475
05/09/2016, 06:43 PM
it can't be the distance from pump to reactor either, from pump to reactor, the line is only 2 feet. The reactor is directly above my sump.

SpectraPure
05/10/2016, 10:11 AM
I still need to understand the operation of the system without any cartridges in it.

It sounds like there's a difference in flow rate between the two sides.

Could you shut off both valves while the pump is running, then open and close each valve, noting the flow rates (they should be the same - one at a time). If they aren't, then there's some kind of blockage on THAT side - the valve itself or something in the tubing or fittings.

You say it's only the GFO side. Just want to make sure I understand.


Support

homer1475
05/11/2016, 05:17 AM
Ok without any cartridges both sides flow the same. With the cartridges installed but empty the GFO still only trickles. Even if I flip the cartridges, the GFO side still only trickles.

I have checked all the hoses and shutoff valves, there is no blockage of any kind in the pipes, and the shutoffs open and close completely. This was my thinking at first also, so I checked those before even making a post.

Thanks for the help by the way!

SpectraPure
05/11/2016, 02:43 PM
Send an email to

support at spectrapure dot com

identifying yourself and shipping information and
we will send you new shells and our GFO. I'd ask
that you pay the shipping.

I could make a guess as to what went wrong - that the
other manufacturer's media might have been really
dusty and quickly clogged up the shell screens.

Support at SpectraPure

SpectraPure
05/14/2016, 09:58 AM
We have not yet heard from you.

Support

homer1475
05/14/2016, 12:03 PM
Been busy at work, sorry. Just emailed [email protected] with my real name, screen name, CC info, and shipping info.


Sent from my STV100-1 using Tapatalk

SpectraPure
05/16/2016, 12:53 PM
Got it. Thank you.

homer1475
05/17/2016, 04:23 AM
No, thank you for trying to make this right. Now this is what customer service should be like. :thumbsup:

SpectraPure
05/17/2016, 03:51 PM
homer,

Can you send me a picture of how the media reactor orients with the Cobalt 1200 pump? I would like to know how high the media reactor is above the pump?

Jeremy

homer1475
05/18/2016, 12:58 PM
I have it taken down right now, but its like 2 feet above the pump.

I got a couple pictures if it helps. Like I mentioned though, as of right now it looks like Frankenstein's monster as I have my mini sitting on the sump with half the parts from the Mr Dual to make the mini work for now. I have a real bad algae issue, so I had to get some GFO running somehow.

Top of the reactor in relation to the pump
http://i84.photobucket.com/albums/k23/homer1475/IMG_20160518_1451141.jpg (http://s84.photobucket.com/user/homer1475/media/IMG_20160518_1451141.jpg.html)

Bottom of the sump where the pump is.
http://i84.photobucket.com/albums/k23/homer1475/IMG_20160518_1451044.jpg (http://s84.photobucket.com/user/homer1475/media/IMG_20160518_1451044.jpg.html)

As you can see, it really is only 2 feet from the pump.

SpectraPure
05/18/2016, 01:10 PM
2 feet is not a problem. Let's wait and see how the new carts work for you.

Support

homer1475
05/19/2016, 01:53 PM
Got the new cartridge and GFO in the mail today(thank you for the fast shipping), except you sent me GAC. :s My invoice says GFO, but what I got is GAC. I have the mini running right now, so I'll need to order some more GFO before I try out the new cartridge.

http://i84.photobucket.com/albums/k23/homer1475/IMG_20160519_1534061.jpg (http://s84.photobucket.com/user/homer1475/media/IMG_20160519_1534061.jpg.html)
http://i84.photobucket.com/albums/k23/homer1475/IMG_20160519_1534219.jpg (http://s84.photobucket.com/user/homer1475/media/IMG_20160519_1534219.jpg.html)
http://i84.photobucket.com/albums/k23/homer1475/IMG_20160519_1535106.jpg (http://s84.photobucket.com/user/homer1475/media/IMG_20160519_1535106.jpg.html)

SpectraPure
05/20/2016, 11:09 AM
Sorry for the mishap. We will send you some GFO, as promised.

Support

SpectraPure
05/20/2016, 11:46 AM
After you receive the Phosphate Media Removal Resin (not "GFO") and you still have problems, try elevating the pump in the sump as much as feasible and see if that makes a difference.

Support

homer1475
05/26/2016, 02:59 PM
Ok got your phosphate removal media(certainly not GFO!). I can certainly see the difference between this and bulk BRS GFO. With your media and new cartridge, it certainly tumbles with no issues.

Thank you very much!

dt204
05/26/2016, 03:48 PM
Nice customer support, thanks spectra pure.
Are we saying that your product is not compatible with most of the bulk GFO products on the market then? I have just purchased the dual reactor as well and haven't received it yet. Haven't purchased any media yet

Sent from my HTC One_M8 using Tapatalk

dt204
05/30/2016, 06:13 PM
Maybe not?

Sent from my HTC One_M8 using Tapatalk

SpectraPure
06/01/2016, 08:59 PM
We use a phosphate media removal resin. It is far superior in removal capabilities than the standard GFO. We are currently rebuilding the unit to see if other configurations will be better.

Jeremy

dt204
06/02/2016, 05:17 AM
Cool, thanks for getting back to me Jeremy. Where's my best place to source your media in Canada?

Sent from my HTC One_M8 using Tapatalk