PDA

View Full Version : Bubble king 160


chevyman1856
11/23/2016, 09:20 AM
Hi having an issue with my 160 pump starts then shuts off this is a gen 2 160 took pump apart and cleaned everything and still doing the same, the impeller spins fine

Thanks
Erik

Sent from my SM-N900V using Tapatalk

slief
11/23/2016, 09:43 AM
How long does it run for? Have you removed the bearing and cleaned the inside of it where the shaft goes in and also made sure the bearing was properly installed once you put the bearing back in place? See post 2 of the thread below.
http://reefcentral.com/forums/showthread.php?t=2573406

If the answer is yes and the impeller only spins for a second or two, then it sounds like your block died. The only other thing to check would be the magnet on the impeller which should be firmly glued/bonded to the shaft and also inspect the impellers magnet for swelling. If the magnet is firmly attached to the shaft and there are no signs of swelling (VERY rare) then you need a new block.

slief
11/23/2016, 09:51 AM
If your block is the much older version that doesn't have the red tube (AKB) that goes between the pump head and the block, then this is the block you need. We don't have them in stock in the US right now so it will have to come from Germany. We are hoping to have our next shipment in the US sometime late next month barring any complications. As such, getting it from Germany may be your best choice if you are in a a hurry.
http://royalexclusiv.net/Spare-Parts/Mini-Red-Dragon-Red-Dragon-1-BK/motor-blocks/part-motor-block-for-Mini-Bubble-King-160-VS07-VS09::185.html

If your block as the red tube (AKB) then this is the block you would need.
http://royalexclusiv.net/Spare-Parts/Mini-Red-Dragon-Red-Dragon-1-BK/motor-blocks/part-motor-block-for-Mini-Bubble-King-160-VS12-with-AKB::1001.html

That said, post a picture of the block. Depending on which model you have, I can probably suggest another block which you can remove from the base and glue to the base from your existing pump. That would save you some shipping since it would come from the US warehouse.

chevyman1856
11/23/2016, 10:36 AM
thanks for the quick replies, it only runs for a 1-seconds, I am going to pull out the bearing tonight, and it does not have the red tube, so yes I would need something fast,

assuming the block is bad, how long to get one from Germany, I am in MA

thanks Erik

slief
11/23/2016, 11:38 AM
thanks for the quick replies, it only runs for a 1-seconds, I am going to pull out the bearing tonight, and it does not have the red tube, so yes I would need something fast,

assuming the block is bad, how long to get one from Germany, I am in MA

thanks Erik

I would guess the shipment would take 7 days (maybe less) from Germany. They use UPS so it should be pretty quick. The prices on the links I provided above include VAT which you won't be charged for. Also, the US dollar is strong against the Euro so overall, the cost won't be much more than US after you factor in shipping. That would probably be your best bet. We have blocks in stock in the US that could be pried from their base and glued to your base. They are the same size blocks so they would fit but they are 1500's and not the 600's so they would consume a bit more more and your skimmer would likely need some adjustments in terms of the wedge pipe since they spin at a higher rate of speed. If it were me, I would get the correct block so you don't mess with the balance of that skimmer.

This is the block you would order.
http://royalexclusiv.net/Spare-Parts/Mini-Red-Dragon-Red-Dragon-1-BK/motor-blocks/part-motor-block-for-Mini-Bubble-King-160-VS07-VS09::185.html