PDA

View Full Version : BRS Mag solution


mlb75
02/08/2017, 03:03 PM
I recently picked up both components of the mag buffer and when I mixed it up it doesn't seem to be mixing. I mixed up two gallons according to the directions 10 cups of one 6 of the other (forget off hand which is which while I'm writing this) and even though I shook it up every couple cups I've still got a fair amount of "sludge" at the bottom of the container. I've let it sit for 2 days now and mix it several times a night by shaking the swirling the liquid but there's still stuff on the bottom and a funky film at the surface. Is this normal?

havasuviking1
02/08/2017, 03:35 PM
Put the jug containing both components into a bucket of hot water. Leave it in the bucket overnight. It will mix easily.

valeriebrs
02/08/2017, 04:03 PM
https://www.youtube.com/watch?v=pQgmVbx34_s&feature=youtu.be&t=5m25s

Quick answer: float the jug in hot water to warm the fluid inside and it should dissolve easier :)

mlb75
02/08/2017, 06:05 PM
It's mixed in a pretty big jug (water cooler bottle) could I just stick a heater in the solution or should I try to swap it to a smaller container and submerge that in a different container?

mlb75
02/08/2017, 06:35 PM
Never mind I put it in a 5 gallon bucket and set that in a Rubbermaid tub with a heater. I'll stir the mix occasionally tonight and see what it looks like in the am.

homer1475
02/17/2017, 04:55 PM
I find the same thing, so what I do is mix up a gallon at a time and set the container on top of my pellet stove. In about an hour it mixes up crystal clear with no sludge at the bottom.

FWIW I do this with the calcium, and alkalinity solution as well. A little heat does wonders.

mlb75
02/21/2017, 01:54 PM
Not sure what happened, after I posted this I submerged the container in a tub with a heater for hours. The water got very warm and after hours of it sitting and stirring and sitting and stirring most of the rest of the media dissolved but it never cleared up and still had a nasty film at the surface.

I did make up a second batch though and it mixed perfectly and was almost crystal clear in no time. The only difference that I can pinpoint was that I mixed it with the water already warm.

I'll try this batch and hopefully the tank will respond.