PDA

View Full Version : Algae


mhalbert14
02/23/2017, 11:32 AM
I'm becoming so frustrated

Ugh so here it goes...

It all started with cyano at the time my nitrates were 40ppm and phosphate was .19
I used chemiclean and tank was good!

One week later I started noticing this copper brown looking algae on one of my rocks. It's starting to produce air bubbles.

I'm also seeing green hair looking algae. It's stating to crawl up a trumpet coral.

My nitrates are low about 10ppm
Phosphate is .09
I'm using poly filters
But my mg is a little over 1600ppm (extra stumped)

Ca could be better about 350

I dosed today with ca.

Can anyone confirm what this brownish color algae is. It's light colored. What do I do? :( I'm stumped. It's like i traded one problem for anotherhttps://uploads.tapatalk-cdn.com/20170223/06e799bd16c8051ba9a535b6cba68e55.jpg

https://uploads.tapatalk-cdn.com/20170223/b9f80e55493d2946591e3252f183134b.jpghttps://uploads.tapatalk-cdn.com/20170223/bcfb17ca9692187dc239f20f08d12b90.jpghttps://uploads.tapatalk-cdn.com/20170223/c0e716d3204a7daff5bd33914b7c1c1e.jpghttps://uploads.tapatalk-cdn.com/20170223/a3e931e68f85fb025ca4278d4abfed55.jpg

.


Sent from my iPhone using Tapatalk

AlSimmons
02/23/2017, 01:14 PM
The links below might help.

http://www.reefcleaners.org/nuisance-algae-id-guide

http://www.reefkeeping.com/issues/2004-05/rhf/index.htm

Ridem32
02/23/2017, 04:23 PM
Get a clean up crew. That will help your tank


Sent from my iPhone using Tapatalk

mhalbert14
02/23/2017, 07:57 PM
The article was very helpful! It's pointed me in the right direction. I have 4 turbos and 3 hermits but clearly that's not enough.

Thanks guys! [emoji1422]


Sent from my iPhone using Tapatalk

Ridem32
02/23/2017, 08:39 PM
Good luck. Keep us updated [emoji106]


Sent from my iPhone using Tapatalk

Ridem32
02/23/2017, 08:42 PM
What state are you in? Profile does not say. 🤠☀️[emoji106]


Sent from my iPhone using Tapatalk

Jessie2406
02/23/2017, 10:10 PM
How old is your tank?

Sent from my SPH-L720 using Tapatalk

mhalbert14
02/23/2017, 10:39 PM
What state are you in? Profile does not say. 🤠☀️[emoji106]


Sent from my iPhone using Tapatalk



Texas


Sent from my iPhone using Tapatalk

mhalbert14
02/23/2017, 10:40 PM
How old is your tank?

Sent from my SPH-L720 using Tapatalk



About 4-5 months although I used some water from my 120 gal.


Sent from my iPhone using Tapatalk

Ridem32
02/23/2017, 11:20 PM
Nothing better than a southern belle with nice aquariums. I'm in Mississippi. We don't have many fish shops. Order most all my stock 🤠[emoji225][emoji226]


Sent from my iPhone using Tapatalk

Jessie2406
02/23/2017, 11:43 PM
About 4-5 months although I used some water from my 120 gal.


Sent from my iPhone using Tapatalk
Did you bring love rock over from your 120 as well? You may just want to let it go through the ugly stage and then maybe try the flucozole treatment for briopsis. Spelling is way wrong on both of those but that's what I've got at 143 am

Sent from my SPH-L720 using Tapatalk

mhalbert14
02/24/2017, 08:23 AM
Did you bring love rock over from your 120 as well? You may just want to let it go through the ugly stage and then maybe try the flucozole treatment for briopsis. Spelling is way wrong on both of those but that's what I've got at 143 am

Sent from my SPH-L720 using Tapatalk



No I had to buy rock. I've heard of it. I need to do more research on it.


Sent from my iPhone using Tapatalk

Ridem32
02/24/2017, 09:04 AM
Do large water changes 2 times a week.


Sent from my iPhone using Tapatalk