PDA

View Full Version : BRS 1.1 dosing pump issues


jcs11236
03/22/2017, 04:07 AM
Just received two brs dosing pumps to replace my apex dos. I had these brs doser years ago and the quality was great. Only problem I seem to be having with these is air bubbles forming in the line. Doesn't seem to be caused by air getting into line by loose nuts but a weird back siphon that occurs when one of the rollers is approaching around the 4oclock mark. Looks like it sucks back and then starts dosing again. That 1 second suck back causes a bubble to form in the line. Is this normal? It is occurring on both the pumps and more or else exactly the same spot when the roller hits the 4oclock mark
Thanks in advance for any info

Randy_BRS
03/22/2017, 09:23 AM
Just received two brs dosing pumps to replace my apex dos. I had these brs doser years ago and the quality was great. Only problem I seem to be having with these is air bubbles forming in the line. Doesn't seem to be caused by air getting into line by loose nuts but a weird back siphon that occurs when one of the rollers is approaching around the 4oclock mark. Looks like it sucks back and then starts dosing again. That 1 second suck back causes a bubble to form in the line. Is this normal? It is occurring on both the pumps and more or else exactly the same spot when the roller hits the 4oclock mark
Thanks in advance for any info

Hey there!

It can be normal, with the low flow rates of the 1.1mL dosing pumps air can get trapped in the line without being purged out as fluid flows through. The dosing pumps should be dosing the same amount, even with small air bubbles in the line. It shouldn't impede the actual flow of the dosing solution through the pump and lines. :D

-Randy