PDA

View Full Version : acan?


postaldave
04/05/2017, 01:12 PM
http://imgur.com/Wkxl8gq

rebooting my tank and bulling the survivors out. this little frag has made it through off the charts nitrates and phosphates. it's never grown or spread just stayed the same since i bought it 5 years ago. i think it was an acan or blastomusa?

this time i'm going to do a better job of knowing what in my tank

postaldave
04/05/2017, 01:14 PM
can't seem to find the edit button. see if this link works.
http://i.imgur.com/Wkxl8gq.jpg

postaldave
04/05/2017, 01:19 PM
http://i.imgur.com/Wkxl8gq.jpg?2

alright last try. and why can't we edit posts here?????

aromano
04/05/2017, 05:57 PM
blasto

postaldave
04/05/2017, 07:42 PM
blasto

is there any reason why it hasn't spread other than water quality? though maybe the plug it was on is stopping it from moving down and growing. like it would be better off on something flatter.

theshaman
04/06/2017, 07:47 AM
The fluctuations in water quality and inadequate light will inhibit growth. Placement in the tank will play a major role too.

Optionman
04/06/2017, 09:37 AM
target feed it

kurt_n
05/01/2017, 10:44 PM
is there any reason why it hasn't spread other than water quality? though maybe the plug it was on is stopping it from moving down and growing. like it would be better off on something flatter.

Definitely Blastomussa, probably Blastomussa wellsi.

They grow up, and out, and sprout new stalks from in between heads. The plug it's on isn't causing issues. It might just be the picture, but it looks a little faded or bleached. To me, that would imply too much light. Blastos don't like a bunch of light. I have mine on the bottom of a medium-light tank, mostly shaded by a duncan. Nice deep red colors should be normal.