PDA

View Full Version : Do I HAVE to update firmware on my apex?


reefer1970
06/14/2017, 05:20 PM
I'm trying to find the answer to my issue of my Apex being disconnected and not being able to control it online. I've unplugged it and reset my router (its hard wired) and last week that solved to problem but now that's not connecting it. My firmware is out of date but I'm scared to do the update and risk screwing it up. My question is: would out of date firmware cause my Apex to be disconnected from the internet until he update it ?


Sent from my iPhone using Tapatalk

mcgyvr
06/14/2017, 05:49 PM
Sure.. A bug/issue in one firmware version could be causing any sort of issue and could be solved by upgrading the firmware..
It could fix it.. Or it doesn't.. Or it causes more problems..
Welcome to electronics/software

slief
06/14/2017, 06:30 PM
Could be bug related but it could also be network related. I would disable DHCP and set the IP to static. You can also try changing the default port from 80 to something like 2024.

ReefCowboy
06/14/2017, 07:49 PM
My apex used to disconnect once in a while when in wifi. I hard wired it and it has been bullet proof for many months. IMO open a ticket with Neptune and let them have a session going over your system. They will update it for you and keep it safe from issues. Trust me it will be worth it

kurt_n
06/14/2017, 09:34 PM
From my experience, firmware may cause connectivity issues but won't keep you from connecting online.

I've always run my Apex wirelessly, and would have occasional network issues with the Apex going offline for 2-4 hours from time to time. It would always correct itself. I just assumed it was my wifi adapter. After I updated my firmware - not having done it for a couple years, staying at 4.20 - the network issues completely disappeared. Completely. I changed nothing else.

So from my data point of one, updating firmware can increase the network stability. But it should *not* be keeping you from connecting.

roberthu526
06/15/2017, 09:31 AM
I had thadame issue in the past. Updated the firmware last week and haven't lost connection since. Fighters crossed.


Sent from my iPhone using Tapatalk

FullBoreReefer
06/15/2017, 10:15 AM
When I updated to 4.52 I've had some issues reconnecting, sometimes I have to do network restarts via apex and/or cycle my dhcp on/off, also have some FMM freezing issues...yes I've opened tickets