PDA

View Full Version : Is my long tentacles anemone dying? Please Help!


JuanManuel
08/07/2017, 12:42 PM
I triple check my water before putting it in, she was doing great eating frozen brien shrimp, but today it's looking like this, my tank is quite old and all fishes and corals are doing great, any advice? Is this look normal!!!????


https://uploads.tapatalk-cdn.com/20170807/e0fb529ebb628cb5ffce22a0bdfbb53a.jpg

https://uploads.tapatalk-cdn.com/20170807/bd18e27a46c376a66e45cd3af28b11a8.jpg


Sent from my iPhone using Tapatalk

Evolve29
08/07/2017, 06:50 PM
How long have you had it opened up?
Mine had its mouth opened for about 2 days and then closed up. Maybe it is gonna expel something? I would just closely monitor it for now.


Sent from my iPhone using Tapatalk

Lance M.
08/07/2017, 08:11 PM
I triple check my water before putting it in,


Did you just recently get the anemone?

Or was this after a water change?

pfan151
08/07/2017, 08:31 PM
Doesn't look like you have enough sand for it. How deep is the sandbed? I'd definitely stop trying to feed it until it looks perfectly healthy.

JuanManuel
08/08/2017, 06:35 AM
Thanks to all the responses! It was just expelling something...

https://uploads.tapatalk-cdn.com/20170808/9daac72d341c922f1c5e2e60f251c2d2.jpg

https://uploads.tapatalk-cdn.com/20170808/2c907204424769f9232f271deb137b28.jpg


Sent from my iPhone using Tapatalk

pfan151
08/08/2017, 07:07 AM
Still doesn't look like it's seated down in the sand like it should be. How deep is your sand?

JuanManuel
08/08/2017, 02:51 PM
How long have you had it opened up?
Mine had its mouth opened for about 2 days and then closed up. Maybe it is gonna expel something? I would just closely monitor it for now.


Sent from my iPhone using Tapatalk



Thanks! Exactly what you said! It's doing fine now


Sent from my iPhone using Tapatalk

Evolve29
08/08/2017, 03:20 PM
Thanks! Exactly what you said! It's doing fine now


Sent from my iPhone using Tapatalk



Awesome! Great looking LT!
Mine is a green one but my orange blood clown keeps digging up sand so the LT doesn't have sand to plant itself. Other than that it is doing well.


Sent from my iPhone using Tapatalk