PDA

View Full Version : DIY Chaeto reactor, with DIY LEDs.


Zephrant
10/05/2017, 01:27 PM
I'm not a fan of the LED strips, they burn out too fast and I'm not confident of their water proof protection. So I'm wanting to do an internal LED setup.

Here is my current plan:
Buy a cheap heater from Amazon and gut it, $12:
https://www.amazon.com/Aquarium-Heater-Submersible-Fish-Water/dp/B06XYXFBL1

Or just a 25mm test tube for $11:
https://www.amazon.com/Rimmed-Glass-Test-Tube-Borosilicate/dp/B00X8CYCA6


I've been unable to find the red/blue grow LEDS on star boards, so have to make my own. I like the star board idea as that will make them easier to attach to a heatsink in this application.
Buy grow light bare LEDs $15:
http://www.topledlight.com/3w-660nm-red-450nm455nm-blue-pink-power-led-beads-emitter-grow-light-bulb-lamp_p1488.html

Put them on star boards $1:
http://www.topledlight.com/aluminium-heatsink-pcb-board-16mm-base-for-1w-3w-5w-luminus-led-flashlight_p1805.html
(Ended up being $25 for 12 of the above LEDs and boards, with shipping included)

Process: Gut the heater (hope the end comes off), or use the test tube. Mount the LEDs on a piece of aluminum bar stock with thermal grease and screws, wire them together and place them inside the heater tube. Seal it up with epoxy or silicone, but I plan to leave the wire end protruding from the top of the reactor for extra safety (I won't submerse it). It will only be 24v DC, but still, I wouldn't trust the tube seal underwater.

Power supply, $6:
https://www.amazon.com/BSOD-Dimming-Transformers-AC85-265V-Constant/dp/B071CJ6M4Q

The heater is 0.875" dia. The test tube is 1", so I'll need a bushing to keep it water tight. One of these will work for both cases, for $2 (ea):
https://www.amazon.com/PG29-18-25mm-Connector-Cable-Gland/dp/B0143YLK02
They have a British thread on them though, so I won't be able to tap the hole they go in, but others I found were much more expensive.

The star boards are 0.65" in dia., so they should fit inside the heater tube without having to sand down the edges.

I'll cut a piece of plate aluminum just big enough to fit in the tube, maybe even round the edges a bit, but I'm concerned about dumping 18w of heat out of that tube. The tube will stay at water temp, but I'm not sure how to get good contact with the metal heatsink that will run up the middle of the tube. I could pot it in epoxy, but I'd expect the epoxy to degrade and discolor over time, unless it was pretty fancy epoxy (expensive). And that would prevent any possibility of repairing it if needed too. If required, I'll put a heatsink head on the top of it, but I'd rather not have that in the way.

As far as the rest of the setup, I have enough acrylic parts left over that I can steal parts from a Kalk reactor and a Waste Collector, and put together a 6" dia. tube that is 16" tall, with 1/4" plumbing inputs, with a twist-lock lid. Since I'll run the water exit to the sump, the entire chamber will be under less than 1psi pressure, so a twist-lock should be fine. The 1/4" plumbing is less than ideal, should be 1/2", but these are the parts I have on hand. I can always drill it out or put in more ports later if desired.

Without making new acrylic parts, I'll have to run the light tube though the twist-off lid, but that's acceptable for a one-off setup.

So grand total is $44, with 6 LEDs left over (less if you have a dead heater laying around) plus the aluminum and acrylic, which I already have.

Parts are on order.

Zephrant
10/05/2017, 01:28 PM
Build process:

First, trim the 6" tube to length, and remove the end which is malformed from the casting process.
http://www.raisedinabarnband.com/rc/IMG_5656.jpg

Here are the parts I had on hand, so will be modifying. Twist-lock cap and flange set, base, and fittings.
http://www.raisedinabarnband.com/rc/IMG_5657.jpg


Assembly: I'll be brief here, as it's covered in many other threads, but I put Weldon #4 in the groove, let it sit for a minute, then slowly lower the tube in to the groove and let it dry. Gives a good clean bond, with no slop.
http://www.raisedinabarnband.com/rc/IMG_5659.jpg

LEDs have not come in yet, it took two weeks to ship. I've gotten the test tube mounted in the flange lid, but didn't take a picture yet, will post again tomorrow.

FireReeferSteve
10/05/2017, 01:54 PM
I did one as well....

https://uploads.tapatalk-cdn.com/20171005/6d919f33bb3d435f36712a4171c0bc3b.jpg

https://uploads.tapatalk-cdn.com/20171005/6db3b45340f61d5a43d0f517bb37df9e.jpg


https://uploads.tapatalk-cdn.com/20171005/fb5367afbfd60343355f1dd13d52571e.jpg

https://uploads.tapatalk-cdn.com/20171005/fbd41c10f07c4147f7e33f9fee6baf3e.jpg

Zephrant
10/05/2017, 03:40 PM
Fly cutter that I used to open up a hole large enough for the 1" cable grommet:

http://www.raisedinabarnband.com/rc/IMG_2674.jpg


I was able to just barely get the nut to fit and bite, but I sealed it with silicon tank sealer and used the nut to help mechanically clamp it together.

http://www.raisedinabarnband.com/rc/IMG_7484.jpg

http://www.raisedinabarnband.com/rc/IMG_9379.jpg

Zephrant
10/05/2017, 03:43 PM
Very nice Steve! Which LEDs and driver did you use? How many watts? Any heat issues?

You are using more LEDs than I was planning, how has it worked out?

FireReeferSteve
10/05/2017, 09:29 PM
Very nice Steve! Which LEDs and driver did you use? How many watts? Any heat issues?

You are using more LEDs than I was planning, how has it worked out?



It's all from rapid leds, Cree LED's is what I'm using and it's a meanwell driver. I'm not currently running it. I'm still in the process of setting up my tank. I had the light on just sitting in the tube and there really was not much heat at all but I'm going to add a small fan. Like a 25mm or something just to flow some air.


Sent from my iPad using Tapatalk

Zephrant
10/10/2017, 06:34 PM
Got the LEDs in and put them on a piece of 1/8" aluminum that I had. Used Arctic Silver epoxy to bond them, then hooked them up to a bench DC source to test.

http://www.raisedinabarnband.com/rc/IMG_5732.jpg

http://www.raisedinabarnband.com/rc/IMG_5734.jpg

Tests on 6 in series:
100ma = 42.1v
150ma = 43.7v
200ma = 44.5v
250ma = 45.7v
300ma = 46.6v

http://www.raisedinabarnband.com/rc/IMG_5733.jpg

Zephrant
10/10/2017, 06:36 PM
I'm thinking that 12 LEDs will be way overkill. I was only planning on six, but I had them all here and I like bright lights...

The power supply won't be in for a month unfortunately, so I'll have to scrounge for something else to use in the mean time.

Zephrant
10/11/2017, 12:17 PM
I decided not to wait until the end of the month for my LED driver from China, so went back to my original plan. Cheap 24v x 1A wall wart, though a PWM box.
I re-wired the LEDs in to four strings of three LEDs each, and ran them in parallel to the PWM box.
I ran the power through a MM and marked off 100ma increments. This power supply will only do 1.1A max, so I can't quite get to full power at 300ma * 4, but close enough. I only intend to run them at 1/2 power or less anyway. I'm not confident I can properly cool them at full power, and they should last forever at 1/2 power.
Dimmer ($6): http://www.topledlight.com/dc-12v24v-8a-led-dimmer-adjustable-brightness-controller_p308.html
http://www.raisedinabarnband.com/rc/IMG_5735.jpg

Here they are at about 1/2 brightness.
http://www.raisedinabarnband.com/rc/IMG_5736.jpg

And again at barely on:
http://www.raisedinabarnband.com/rc/IMG_5737.jpg

This is the cheap AC transformer I got:
http://www.raisedinabarnband.com/rc/IMG_5738.jpg

I'm not confident of the longevity of this setup- That's not an official current limited LED driver, so I might blow it using it this way. And I don't know how it's components will react to the PWM creating current spikes over time either. But I'll update this if I do blow it.

At the very least, it should last until my official LED driver comes in later.

FireReeferSteve
10/11/2017, 02:07 PM
Here is what I came up with for mine. 12 leds mix of red’s and a couple blues added. Second pic is of the strip inside the center tube of reactor.

https://uploads.tapatalk-cdn.com/20171011/8d3c9148c74ce22074797a701b8319a4.jpg

https://uploads.tapatalk-cdn.com/20171011/c68373b2faf4312593e74fc5ffd70d59.jpg


Sent from my iPhone using Tapatalk

Zephrant
10/11/2017, 04:05 PM
Pulled out the IR camera to check temperature. This is running at approx 500ma total, or 125ma per LED. I let it warm up for 5+ minutes.
I placed scotch tape pieces on the aluminum so I could read an accurate temp. Otherwise, it just reads whatever is reflected off the aluminum.

http://www.raisedinabarnband.com/rc/IR_0413.jpg
http://www.raisedinabarnband.com/rc/IR_0414.jpg
http://www.raisedinabarnband.com/rc/IR_0415.jpg

Looking online, I see some derating charts for LEDs like this one from here (http://www.mouser.com/applications/lighting-derating/):
http://www.mouser.com/images/microsites/recom-derating-graph05.jpg

Graph 1 shows an ideal LED current verses temperature relationship. Up to the manufacturer’s specified maximum operating temperature, the LED current remains constant. As the LED temperature exceeds the limit, the current and therefore the power is reduced and the LED dimmed to protect it from overheating. This curve is called a “Derating Curve” and keeps the LED working within its safe power dissipation limits. The 55°C “threshold” temperature in the above graph is the base plate or heat sink temperature – the LED itself will be typically 15°C warmer (i.e. 70°C) and the internal junction temperature close to 35°C warmer (i.e. 90°C). Thus 55°C is thus a safe full power limit, although it could be increased to a maximum of 65°C for high performance LED lamps.

That implies that I can run up to about 55c at the LED base-plate without impacting performance.

Zephrant
10/11/2017, 04:25 PM
Looks great- Would like to see how hot it gets for you when you get it wet.

The LEDs I picked have two smaller red and one large blue chip inside each module. Specifically designed for grow lights I guess. Would like to get a spectrum from them though.

Zephrant
10/12/2017, 01:00 PM
Got it running last night- Had to sand the aluminum a little to get the LEDs to slide in to the tube. Set it to 300ma and was reading about 110F on the end of the heatsink this morning, after about 10 hours of running. So a little warm, but not too bad.

I wrapped it with mylar to block the light. Had to steal a space blanking from the camping stuff, couldn't find any other reasonable source. Works well for blocking the light, very little leaks though.

http://www.raisedinabarnband.com/rc/IMG_1253.jpg

Put in a mostly dead ball of chaeto, will see if can grow at all. I love how I can look down through the tinted top and see what's going on inside.
http://www.raisedinabarnband.com/rc/IMG_1267.jpg

I'd recommend going with 1/2" fittings for better flow, I'm at about 250ml/min flow rate.

I'm planning on going with mineral oil immersion when it's time to turn up the power. I don't want to fry the LEDs, and I'm thinking it will get too hot if I go up any higher. I have stoppers on order, so I'll just fill the tube with oil and see how it goes. I expect it to transfer heat to the glass tube a lot better, so I should be able to run it at full power if I want to nuke the algae.