PDA

View Full Version : Seio Pumps


PelagicMagic
02/23/2006, 08:49 AM
I need some feedback/reviews from seio owners on these pumps before I buy. How do you like them? Do they give off alot of heat? How is the flow. I would buy the tunze but they are too expensive for my 180 setup, maybe if I had an inwall that was over 250g but not for my dinky 180

I am going to get 2-1500's for my 180


thanks,

prugs
02/23/2006, 09:23 AM
My seio's never start after the power goes out.

PelagicMagic
02/23/2006, 09:39 AM
how do you restart it? remove it then resubmerge it?

Highlander
02/23/2006, 09:44 AM
I use two of the 1500s to add circulation as a compliment to my wave box in my 180.
The Seios need to be kept clean, I run mine in vinegar for a couple of hours each month, and they run like a dream.

Toddrtrex
02/23/2006, 10:46 AM
I have 3 620s in my 58 for just over a year now. I clean them about every 3-4 months. And horror of all horrors I am running them off the wavemaker section of my Reefkeeper. I have never had an issue with them not restarting.

PelagicMagic
02/23/2006, 11:24 AM
just got 2 1500's on my lunch break and installed them. I am very happy

prugs
02/24/2006, 08:30 AM
<a href=showthread.php?s=&postid=6808144#post6808144 target=_blank>Originally posted</a> by prugs
My seio's never start after the power goes out.

I bought some 1100 models. Didn't start on their own right out of the box. I have to tap the impeller with a stick while they are under water. Lots of nice flow, but.

cristhiam
02/24/2006, 09:39 AM
I'm using this mod for a MJ1200 works great. I just order another one. I'll have two in my 125 tons of flow :) Check out the thread in the diy forum
http://www.home.earthlink.net/~pinatas/DSC00002.jpg
http://www.home.earthlink.net/~pinatas/DSC00003.jpg

Leviathan
02/24/2006, 09:46 AM
I HAD 2 of the 1100's in my 90 gallon tank before selling the system off. They NEVER restarted and were literally a PITB to get going again. One simply gave out completely after several weeks. The other I still have, I loved the flow WHEN they worked, but in afterthought wish I had just saved up for a better pump.

prugs
02/24/2006, 03:43 PM
<a href=showthread.php?s=&postid=6816243#post6816243 target=_blank>Originally posted</a> by cristhiam
I'm using this mod for a MJ1200 works great. I just order another one. I'll have two in my 125 tons of flow :) Check out the thread in the diy forum
http://www.home.earthlink.net/~pinatas/DSC00002.jpg
http://www.home.earthlink.net/~pinatas/DSC00003.jpg

I didn't know they were for sale. I thought it was just experimental.
Where did you order from?

Andrew
02/24/2006, 04:16 PM
Ive got 2- 620s and im order 2-1100s and im very happy with the seio pumps. No problems yet.

Rungeg
02/24/2006, 05:25 PM
I use two 1100 in my 75, that may not be enough flow depending on what you are keeping, and cristhiam holy xenia

PelagicMagic
02/24/2006, 05:40 PM
1 have 2 1500's on the 180 and its enough IMO

want2reef
02/24/2006, 05:55 PM
I use one 1100 and two Maxi-Streams in my 120G.

dhnguyen
02/24/2006, 05:59 PM
<a href=showthread.php?s=&postid=6819084#post6819084 target=_blank>Originally posted</a> by prugs
I didn't know they were for sale. I thought it was just experimental.
Where did you order from?


Everything starts out as an experiment :)

We've come a long way since then on this thread.

Check it out.

http://reefcentral.com/forums/showthread.php?s=&threadid=717034

A little long but well worth the time :)

frags4u
02/24/2006, 06:06 PM
HOLY COW NOW THAT IS SOME XENIA HEHE

cristhiam
02/24/2006, 07:33 PM
That's just the corner :) too bad I took the 55 down and upgrade to 125 over the weekend :)
http://www.home.earthlink.net/~pinatas/fulltank003.jpg

KingSpade
02/24/2006, 10:55 PM
i have 4 seio M1500's in my 125, well i bought 4 and only have 2 in, im afraid of what the other 2 will do, TONS of flow with 2!!

hahnmeister
02/25/2006, 01:47 AM
Ok, so who sells the conversion kits for the MJs? Im sold...

ohioreef
02/25/2006, 02:04 AM
2-Seio 620s in my 75with no problems!!

Do like the looks of the MJ mod.

cristhiam
02/25/2006, 06:43 AM
I got mine from Lutz493

need4reef
02/25/2006, 07:42 AM
I put 2 2600s in my 150 four weeks ago and I have not had a single problem with them. they are restarting every time for me!