Reef Central Online Community

Home Forum Here you can view your subscribed threads, work with private messages and edit your profile and preferences View New Posts View Today's Posts

Find other members Frequently Asked Questions Search Reefkeeping ...an online magazine for marine aquarists Support our sponsors and mention Reef Central

Go Back   Reef Central Online Community > Sponsor Forums > SpectraPure
Register Blogs FAQ Calendar Mark Forums Read

Notices

Reply
Thread Tools
Old 08/16/2011, 01:55 PM   #1
snorvich
Team RC member
 
snorvich's Avatar
 
Join Date: Aug 2005
Location: Outlander
Posts: 41,247
Blog Entries: 46
"Bad" membrane MEM-090

I am a big user of your equipment (I have two systems and stockpile your filters and membranes). I just opened a new membrane MEM-090 and written on it in magic marker is "Bad 71gpd 94%". Clearly that is not a good thing. How are you going to fix that for me?


__________________
Warmest regards,
~Steve~
snorvich is offline   Reply With Quote
Old 08/16/2011, 02:20 PM   #2
SpectraPure
RC Sponsor
 
SpectraPure's Avatar
 
Join Date: Jun 2003
Posts: 4,618
replace it of course! Sounds like someone in a hurry pulled from the bad bin. I will bring this problem to mfg supervisor's attn as this stash is supposed to be returned to the vendor (not sent to customers!) All that testing we do is supposed to make sure you get a tested product with our name on it, and our name isnt "bad".
Sorry for the mix up!
You can call or email with your purchase info and we will drop a replacement in todays mail.
bruce



Last edited by SpectraPure; 08/16/2011 at 02:30 PM.
SpectraPure is offline   Reply With Quote
Old 08/16/2011, 02:46 PM   #3
SpectraPure
RC Sponsor
 
SpectraPure's Avatar
 
Join Date: Jun 2003
Posts: 4,618
Could you shoot me a picture also? Our MEM-0090 do not have labels with test information written on them. I am trying to figure out how we sent you a bad "MEM-0090" membrane as what you describe sounds like a reject "MEM-S-0090" which could have been labelled in such a manner if it failed the individual test criteria.

Also, did you buy it from us or elsewhere? Thanks for the help. I just want to make sure that we cannot make the same mistake in the future, and yoru information will help us determine how this mishap may have occured.
bruce


SpectraPure is offline   Reply With Quote
Old 08/16/2011, 02:53 PM   #4
snorvich
Team RC member
 
snorvich's Avatar
 
Join Date: Aug 2005
Location: Outlander
Posts: 41,247
Blog Entries: 46
Quote:
Originally Posted by SpectraPure View Post
Could you shoot me a picture also? Our MEM-0090 do not have labels with test information written on them. I am trying to figure out how we sent you a bad "MEM-0090" membrane as what you describe sounds like a reject "MEM-S-0090" which could have been labelled in such a manner if it failed the individual test criteria.

Also, did you buy it from us or elsewhere? Thanks for the help. I just want to make sure that we cannot make the same mistake in the future, and yoru information will help us determine how this mishap may have occured.
bruce
I will be happy to send it to you if you like. Picture can happen next Tuesday as my aquarium guy has a picture phone. I am sending my address, etc. via email to you now. I buy all my stuff directly from you.


__________________
Warmest regards,
~Steve~
snorvich is offline   Reply With Quote
Old 08/16/2011, 04:23 PM   #5
snorvich
Team RC member
 
snorvich's Avatar
 
Join Date: Aug 2005
Location: Outlander
Posts: 41,247
Blog Entries: 46
Did you receive email with my information?


__________________
Warmest regards,
~Steve~
snorvich is offline   Reply With Quote
Old 08/16/2011, 04:39 PM   #6
SpectraPure
RC Sponsor
 
SpectraPure's Avatar
 
Join Date: Jun 2003
Posts: 4,618
No, who did you send it to?

Try support at spectrapure dot com .


SpectraPure is offline   Reply With Quote
Old 08/16/2011, 05:34 PM   #7
snorvich
Team RC member
 
snorvich's Avatar
 
Join Date: Aug 2005
Location: Outlander
Posts: 41,247
Blog Entries: 46
I sent it through RC but just resent it to the address specified above. Please let me know when you receive it. Thanks for the great support.


__________________
Warmest regards,
~Steve~
snorvich is offline   Reply With Quote
Old 08/16/2011, 06:19 PM   #8
SpectraPure
RC Sponsor
 
SpectraPure's Avatar
 
Join Date: Jun 2003
Posts: 4,618
Got it.

Bruce


SpectraPure is offline   Reply With Quote
Old 08/17/2011, 10:59 AM   #9
SpectraPure
RC Sponsor
 
SpectraPure's Avatar
 
Join Date: Jun 2003
Posts: 4,618
Aha! I see from your order details that you bought (2) MEM-S 90 membranes, which explains the label being filled out (standard membranes would not have this level of detail). I will send you one tested MEM-S-90 today plus a spare sediment filter for your troubles.

Sorry, we held a Mfg/Shipping team review and what we found is that the separate storage of membranes (not for sale) somehow ended up in the same storage location as those to be sold. We know how this happened, but naming the owner of the company as the root cause of the problem is bad form :-)

They have since been relocated back to the original quarantined product storage area where they cannot be accidently grabbed.

Thanks for helping us figure this out.



Bruce


SpectraPure is offline   Reply With Quote
Old 11/21/2017, 08:04 PM   #10
Brooklyn11220
Registered Member
 
Join Date: May 2011
Location: Brooklyn
Posts: 18
?

So if there's handwriting then it's bad? Mine has 98% and a date handwritten


Brooklyn11220 is offline   Reply With Quote
Old 11/21/2017, 08:09 PM   #11
SpectraPure
RC Sponsor
 
SpectraPure's Avatar
 
Join Date: Jun 2003
Posts: 4,618
This thread is 6 years old.


__________________
Innovators in water technology.
Since 1985!
SpectraPure is offline   Reply With Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump

Similar Threads
thread Thread Starter Forum Replies Last Post
Piggyback membrane for ro/di unit scubasteve3403 Reef Discussion 1 10/02/2011 05:35 PM
What's the best place for RO/DI replacement filt./mem.? mikenazo Southern California Reefers 4 09/22/2008 06:14 PM
Which Mem for my Toms??? RicardoUK Anemones & Clownfish 8 10/13/2007 07:29 PM


All times are GMT -6. The time now is 12:25 PM.


TapaTalk Enabled

Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2017 Axivo Inc.
Use of this web site is subject to the terms and conditions described in the user agreement.
Reef CentralTM Reef Central, LLC. Copyright 1999-2014