Reef Central Online Community
Blue Zoo Aquatics

Home Forum Here you can view your subscribed threads, work with private messages and edit your profile and preferences View New Posts View Today's Posts

Find other members Frequently Asked Questions Search Reefkeeping ...an online magazine for marine aquarists Support our sponsors and mention Reef Central

Go Back   Reef Central Online Community > Sponsor Forums > Proline Aquatics / Royal-Exclusiv
Register Blogs FAQ Calendar Mark Forums Read

Notices

 
Thread Tools
Old 05/02/2008, 10:03 AM   #1
skamin
Registered Member
 
Join Date: Mar 2004
Location: Dallas
Posts: 75
Skimmer Pump - Red Dragon 2000

I recently purchased a replacement pump for a Bubble King 300 internal. Every time i cleaned the old RD 2000 pump the impeller assembly would work itself forward and rub on the housing and stop turning within a hour or two of putting it back togehter. is there a way to prevent that from happening? I bought the other pump to have a back up, but now as the origianl one is not working i am again left with out a back up.

Also I noticed that the front end housing of the new pump is significantly different than the origianl, like maybe it was for an external 300 instead. is it ok to run it internally with that other front end housing?

thanks.

Stan


skamin is offline  
Old 05/02/2008, 10:47 AM   #2
Proline
Registered Member
 
Proline's Avatar
 
Join Date: Nov 2006
Location: Vancouver
Posts: 950
Hi Stan
The pump for the Int & Ext is the same.
I am not sure how this could happen ,my only guess ,is the rubber bushing @ the end of the shaft intact ?
Can you please send a picture of the impeller & front housing if possible.
Regards
Chris


Proline is offline  
Old 05/28/2008, 08:49 PM   #3
skamin
Registered Member
 
Join Date: Mar 2004
Location: Dallas
Posts: 75
RD 2000

Hey Chris is there a email address I can send photos? I am having no luck posting them.

thanks

Stan


skamin is offline  
Old 06/10/2008, 01:47 PM   #5
skamin
Registered Member
 
Join Date: Mar 2004
Location: Dallas
Posts: 75
I sent all the pictures in....any updates yet?

thanks

Stan


skamin is offline  
Old 06/10/2008, 02:18 PM   #6
Proline
Registered Member
 
Proline's Avatar
 
Join Date: Nov 2006
Location: Vancouver
Posts: 950
Stan
Please check your email ,I sent you my cell # call me anytime & we will take care of this for you.
Regards
Albert


Proline is offline  
 

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -6. The time now is 09:59 AM.


TapaTalk Enabled

Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Use of this web site is subject to the terms and conditions described in the user agreement.
Reef CentralTM Reef Central, LLC. Copyright 1999-2014