Reef Central Online Community
Marine Depot

Home Forum Here you can view your subscribed threads, work with private messages and edit your profile and preferences View New Posts View Today's Posts

Find other members Frequently Asked Questions Search Reefkeeping ...an online magazine for marine aquarists Support our sponsors and mention Reef Central

Go Back   Reef Central Online Community > Sponsor Forums > Neptune Systems
Register Blogs FAQ Calendar Mark Forums Read

Notices

User Tag List

Reply
Thread Tools
Old 07/30/2008, 11:36 AM   #1
MinibowMatt
Registered Member
 
MinibowMatt's Avatar
 
Join Date: Feb 2005
Location: In Another Times Forgotten Space
Posts: 3,389
program issues? UNK status

I am having an "unk" status after my heater, regardless of what state its actually in. Its not really a problem, as my controller is functioning fine at the moment. I had issues with my temp probe, got an RMA for a new , lost that emailand never got a new one.
I just re-plugged in my original temp probe to see what would happen, and it works fine. I needed to compensate the temp in the program, (it was off 2 degrees) but its holding temp.
SO Why am I getting unk in the status of my heater?

Here is the program I am running (yes I know I have a lot of ATO statements, but I only want my ATO kicking on when I am home.)

If Time > 16:00 Then MH1 ON
If Time > 14:00 Then FRG ON
If Time > 21:30 Then MH1 OFF
If Time > 21:30 Then FRG OFF
If Time > 14:00 Then ACT ON
If Time > 23:30 Then ACT OFF
If Time > 21:18 Then FG1 ON
If Time > 12:35 Then FG1 OFF
If Time > 05:35 Then ATO ON
If Time > 06:15 Then ATO OFF
If Time > 15:00 Then ATO ON
If Time > 15:40 Then ATO OFF
If Time > 22:00 Then ATO ON
If Time > 22:40 Then ATO OFF
If Time > 05:00 Then ATO ON
If Time > 05:50 Then ATO OFF
If Temp < 77.5 Then HET ON
If Temp > 79.0 Then HET OFF
If Temp > 84.8 Then MH1 OFF
If Temp > 83.8 Then FRG OFF
If Time > 00:00 Then RET ON
If FeedA 000 Then RET OFF
If FeedA 020 Then SKM OFF


__________________
-----------------------
Matt
Prop & Save!

"Sure dont know what I'm going for, but I'm gonna go for it for sure!"
MinibowMatt is offline   Reply With Quote
Old 07/30/2008, 11:49 AM   #2
kenargo
Premium Member
 
kenargo's Avatar
 
Join Date: Jan 2007
Location: Redmond, WA
Posts: 8,151
You are fine. 'UNK' is reported when then AC does not understand the state of a timer. It is nearly always seen just after an AC program restart which happens after program updates, AC reset ets. It should go away on its own.

Here is why you see it; I will start by saying there is nothing wrong with your HET program!

If Temp < 77.5 Then HET ON
If Temp > 79.0 Then HET OFF

This is your program. If the AC program is restarted and the tank temp is 78.0 the test of both statements will be false because 78 is not < 77.5 and not > 79. In this condition the AC doesn't know what to do with the HET timer so UNK is displayed. The HET timer will not be changed from what it was, on or off but it doesn't matter and here is why. If HET happened to be off then sooner or later the tank will cool off and get < 77.5 at which time the 1st statement will be true and HET will change to ON. If the HET happened to be on then sooner or later the tank temp will hit 79.1 and the second statement will become true and HET will be turned off.

Hope this helps.


__________________
Click on my name to visit my homepage and access a collection of AquaController and Apex software, tips, trick and other Q&A including a link to the 'unofficial Apex new users guide' with loads of helpful information and don't forget to put a pin in my location map.

Current Tank Info: 225G, BK 300 Deluxe, Deltec PF601, Precision Marine Kalkreactor, 2-LMIII+6 pumps, SpectraPure UHE, Apex, LunarSim, Tunze 6305s. Mixed reef, clam, fish, etc.
kenargo is offline   Reply With Quote
Old 07/30/2008, 11:50 AM   #3
kenargo
Premium Member
 
kenargo's Avatar
 
Join Date: Jan 2007
Location: Redmond, WA
Posts: 8,151
One note about your program; you may want to add something like the following to protect against temp probe failure:

If Temp < 75.5 Then HET OFF


__________________
Click on my name to visit my homepage and access a collection of AquaController and Apex software, tips, trick and other Q&A including a link to the 'unofficial Apex new users guide' with loads of helpful information and don't forget to put a pin in my location map.

Current Tank Info: 225G, BK 300 Deluxe, Deltec PF601, Precision Marine Kalkreactor, 2-LMIII+6 pumps, SpectraPure UHE, Apex, LunarSim, Tunze 6305s. Mixed reef, clam, fish, etc.
kenargo is offline   Reply With Quote
Old 07/30/2008, 11:54 AM   #4
MinibowMatt
Registered Member
 
MinibowMatt's Avatar
 
Join Date: Feb 2005
Location: In Another Times Forgotten Space
Posts: 3,389
Thanx Ken!
I knew it wasnt effecting the program, but wanted to be sure. I have had this for almost a year now, and have barely tapped into it. Now that I have a dedicated comp for it, I expect to have many more problems.


__________________
-----------------------
Matt
Prop & Save!

"Sure dont know what I'm going for, but I'm gonna go for it for sure!"
MinibowMatt is offline   Reply With Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump


All times are GMT -6. The time now is 11:54 PM.


TapaTalk Enabled

Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2020 Axivo Inc.
Use of this web site is subject to the terms and conditions described in the user agreement.
Reef CentralTM Reef Central, LLC. Copyright 1999-2014
User Alert System provided by Advanced User Tagging v3.3.0 (Pro) - vBulletin Mods & Addons Copyright © 2020 DragonByte Technologies Ltd.