Reef Central Online Community
SpectraPure

Home Forum Here you can view your subscribed threads, work with private messages and edit your profile and preferences View New Posts View Today's Posts

Find other members Frequently Asked Questions Search Reefkeeping ...an online magazine for marine aquarists Support our sponsors and mention Reef Central

Go Back   Reef Central Online Community > Sponsor Forums > SpectraPure
Register Blogs FAQ Calendar Mark Forums Read

Notices

Reply
Thread Tools
Old 03/30/2015, 10:33 AM   #1
SpectraPure
RC Sponsor
 
SpectraPure's Avatar
 
Join Date: Jun 2003
Posts: 4,616
WANTED: Customer Service Feedback- Good or bad!

I want your feedback on our customer service, good or bad. We strive to improve, and also like to hear from you when we do (or do not). Altough you can always post here, or pm our technical service team here, I also want to give you a way to speak directly to me, good or bad.

If you received superior service, had a bad experience, or have ideas on how to improve our customer experience we have added a feedback "direct to management" tab on our website on the homepage:

http://spectrapure.com/index.php?route=common/home

on the right (orange tab) and also at the bottom "How are we doing"

Thank you for your help.

Bruce


__________________
Innovators in water technology.
Since 1985!
SpectraPure is offline   Reply With Quote
Old 01/11/2016, 10:13 PM   #2
eforum
Registered Member
 
Join Date: Jan 2016
Posts: 1
I just wanted to drop by and say thanks to Jeremy for his awesome service today! I will be replacing my AquaticLife RO Buddie system with a 5-stage Spectrapure this week. Customer service is very responsive and helpful!


eforum is offline   Reply With Quote
Old 01/23/2016, 10:55 AM   #3
Klott
Registered Member
 
Join Date: Oct 2008
Posts: 14
Warranty Issue

First, I am not one regularly rant publicly about customer service issues. In the case of unsatisfactory customer service, I simply chose to spend my money elsewhere. However, I read the invitation on this forum to provide feedback so here it is.

I purchased a UPLC-II Liquid Level Controller in January 2014 to handle delivery of limewater for my 300 gallon reef. The unit was operated outside the stand and worked fine until October 2015 when the pump started working intermittently before it stopped working at all. The indicator lights stopped working as well.

I contacted SpectraPure and was given a RMA and returned the unit. After a month or so, I contact SpectraPure to get an update and was told that the board was dead and that the motor was seized with rust. I was asked if there was a leak in the pump or if the pump was in an area of a large amount of salt water evaporation. I replied that I never observed a leak and that the pump was located outside of the stand where I would not assume a large amount of evaporation.

In response, I received a message indicating that the tubing must not have been in all the way and water leaked inside the pump causing the pump to rust. I am not sure of why the unit failed, but I am sure that tubing was inserted all the way. In fact the pump is used to deliver supersaturated limewater. If limewater leaked inside of the pump, it would be very apparent. I was offered to pay for a replacement pump, board, and return shipping at a reduced price of approximately $70. While I am sure that this is a good deal under other circumstances, I am struggling with the idea of spending more money on a pump that did not hold up under what I would consider normal and is not been deemed to be covered by warranty. I do have other dosing pumps, ironically controlled by a Spectra Pure Power Head Liquid Level Controller that are actually mounted in the stand that have held up fine.


Klott is offline   Reply With Quote
Old 01/26/2016, 10:50 AM   #4
SpectraPure
RC Sponsor
 
SpectraPure's Avatar
 
Join Date: Jun 2003
Posts: 4,616
Quote:
Originally Posted by Klott View Post
First, I am not one regularly rant publicly about customer service issues. In the case of unsatisfactory customer service, I simply chose to spend my money elsewhere. However, I read the invitation on this forum to provide feedback so here it is.

I purchased a UPLC-II Liquid Level Controller in January 2014 to handle delivery of limewater for my 300 gallon reef. The unit was operated outside the stand and worked fine until October 2015 when the pump started working intermittently before it stopped working at all. The indicator lights stopped working as well.

I contacted SpectraPure and was given a RMA and returned the unit. After a month or so, I contact SpectraPure to get an update and was told that the board was dead and that the motor was seized with rust. I was asked if there was a leak in the pump or if the pump was in an area of a large amount of salt water evaporation. I replied that I never observed a leak and that the pump was located outside of the stand where I would not assume a large amount of evaporation.

In response, I received a message indicating that the tubing must not have been in all the way and water leaked inside the pump causing the pump to rust. I am not sure of why the unit failed, but I am sure that tubing was inserted all the way. In fact the pump is used to deliver supersaturated limewater. If limewater leaked inside of the pump, it would be very apparent. I was offered to pay for a replacement pump, board, and return shipping at a reduced price of approximately $70. While I am sure that this is a good deal under other circumstances, I am struggling with the idea of spending more money on a pump that did not hold up under what I would consider normal and is not been deemed to be covered by warranty. I do have other dosing pumps, ironically controlled by a Spectra Pure Power Head Liquid Level Controller that are actually mounted in the stand that have held up fine.
Keith,

We got the pump back and there was rust inside of the pump. We pressure tested the tubing, and it was perfectly fine. The only way rust gets inside of the pump are follows below:

Punctured tubing
tubing not fully seated
water from above dripping down into the pump
Salt water evaporation

If the tubing wasn't punctured how did the inside of the pump rust? I go out of my way to help people. I extend the range of what I am supposed to do to go above and beyond.

We could have spoken more about this without resulting in a bad review. I am sure that we could have come to an agreement as I am a pretty reasonable man.

If you want to give it another shot I am sure we can figure out something.

Jeremy


__________________
Innovators in water technology.
Since 1985!
SpectraPure is offline   Reply With Quote
Old 01/26/2016, 05:09 PM   #5
SpectraPure
RC Sponsor
 
SpectraPure's Avatar
 
Join Date: Jun 2003
Posts: 4,616
I am sorry.
Please contact us, I would like to make this right too.
While the damage found supported Jeremy's assessment above, as Jeremy said we still want you happy with our product.
I accept your offer for a $70 refurbishment.
Contact Jeremy and he will definitely take it a step above to make this happen for you.

Bruce


__________________
Innovators in water technology.
Since 1985!
SpectraPure is offline   Reply With Quote
Old 01/27/2016, 10:59 PM   #6
Klott
Registered Member
 
Join Date: Oct 2008
Posts: 14
Thank You For Your Response

Thank you for your response. I appreciate the proposed resolution that was e-mailed today and look forward to proceeding.


Klott is offline   Reply With Quote
Old 02/01/2016, 02:21 AM   #7
SpectraPure
RC Sponsor
 
SpectraPure's Avatar
 
Join Date: Jun 2003
Posts: 4,616
Thumbs up

Quote:
Originally Posted by Klott View Post
Thank you for your response. I appreciate the proposed resolution that was e-mailed today and look forward to proceeding.
Thanks!


__________________
Innovators in water technology.
Since 1985!
SpectraPure is offline   Reply With Quote
Old 02/27/2016, 10:23 PM   #8
triggreef
Registered Member
 
triggreef's Avatar
 
Join Date: Aug 2012
Location: East Hampton, CT
Posts: 2,929
I never had any complaints. The quality of spectrapure filters is great and last longer than other vendors IMO IME.


__________________
200g DD Marineland. Acro and monti heavy with some birdsnest, LPS, and zoas. 125g FOWLR
triggreef is offline   Reply With Quote
Old 03/02/2016, 11:19 PM   #9
SpectraPure
RC Sponsor
 
SpectraPure's Avatar
 
Join Date: Jun 2003
Posts: 4,616
Thank you very much!!!


Jeremy


__________________
Innovators in water technology.
Since 1985!
SpectraPure is offline   Reply With Quote
Old 04/05/2016, 02:14 PM   #10
CStrickland
Registered Member
 
CStrickland's Avatar
 
Join Date: Jan 2015
Location: New England, U.S.
Posts: 4,599
Jeremy did a super job helping me figure out why my ratio dropped and getting it back up to snuff


__________________
If you're havin tank problems I feel bad for you, son. I got 99 problems but a fish ain't one

Current Tank Info: 3/2016 upgrade to 120g. Chalk bass, melanurus, firefish, starry blenny, canary blenny, lyretail anthias, engineer gobys, kole tang. Softies / LPS / NPS. <3 noob4life <3
CStrickland is offline   Reply With Quote
Old 04/08/2016, 12:24 PM   #11
SpectraPure
RC Sponsor
 
SpectraPure's Avatar
 
Join Date: Jun 2003
Posts: 4,616
It was my pleasure.

Jeremy


__________________
Innovators in water technology.
Since 1985!
SpectraPure is offline   Reply With Quote
Old 04/13/2016, 10:37 PM   #12
AZRippster
Diver & Reef Aquarium Nut
 
AZRippster's Avatar
 
Join Date: May 2012
Location: Sierra Vista, AZ
Posts: 1,135
Monster Kudos to SpectraPure!!

This Tuesday I found that my RODI system had slowed in its output leading me to investigate. After replacing the sediment, carbon blocks, and DI resin, the problem persisted. The house's main water pressure remained good so I figured it had to be my RO membrane which was installed 11 Oct 15. I live in a small town that doesn't lead itself to having items such as this on hand. I called SpectraPure yesterday morning (Wednesday) asking if they could expedite one out to me being I was leaving on vacation Friday morning and needed this installed ASAP. I was assured they would do their best.

Around noon yesterday (Wednesday) I checked my email to find they had already shipped the membrane and had provided tracking information that actually showed USPS had picked up the package. It was waiting for me today when I got home from work (Thursday). It is now installed, flushed, and back to producing excellent water for my aquaria.

Monster Kudos go out to SpectraPure for helping me out and helping to ease my mind about leaving for a trip.

A million thanks!!!!


__________________
I wish winter was coming, it's been hotter than hell this year!

Current Tank Info: 450 Gallon Rebuild In Progress
AZRippster is online now   Reply With Quote
Old 04/18/2016, 01:03 PM   #13
SpectraPure
RC Sponsor
 
SpectraPure's Avatar
 
Join Date: Jun 2003
Posts: 4,616
That's cool! Thanks for the feedback! You are awesome!!!

Jeremy


__________________
Innovators in water technology.
Since 1985!
SpectraPure is offline   Reply With Quote
Old 05/26/2016, 04:04 PM   #14
homer1475
Registered Member
 
homer1475's Avatar
 
Join Date: Mar 2015
Location: Upstate NY
Posts: 3,898
These guys have excellent customer service!

I had an issue with their Mr Dual media reactor, and these guys went above and beyond to fix the issue. I have absolutely no complaints about my order, or how they handled my issue.


__________________
80G SCA Build: http://reefcentral.com/forums/showthread.php?t=2560256

Biocube Build Thread: http://www.reefcentral.com/forums/showthread.php?t=2499945

Nothing in this hobby happens fast!
homer1475 is offline   Reply With Quote
Old 07/08/2016, 12:25 PM   #15
SpectraPure
RC Sponsor
 
SpectraPure's Avatar
 
Join Date: Jun 2003
Posts: 4,616
Thank you for the kind words.


__________________
Innovators in water technology.
Since 1985!
SpectraPure is offline   Reply With Quote
Old 07/13/2016, 08:08 PM   #16
GQuinn
Registered Member
 
Join Date: Feb 2005
Location: Northern Indiana
Posts: 944
Called in a couple of times for help on a litermeter 3. Left a message both times and no one called me back. So, I wasn't overly impressed with customer service. I finally figured it out myself.


GQuinn is online now   Reply With Quote
Old 07/19/2016, 06:09 PM   #17
SpectraPure
RC Sponsor
 
SpectraPure's Avatar
 
Join Date: Jun 2003
Posts: 4,616
Gquinn,

did you call the support line or the sales line? I manage the support line. If you called there you should have gotten a call back. I typically leave messages, and often times I call using Skype. I am curious as to the problem you had, and the fix you found. There might be something else to look at as well.

Jeremy


__________________
Innovators in water technology.
Since 1985!
SpectraPure is offline   Reply With Quote
Old 08/02/2016, 08:45 PM   #18
atraperegrinus
Registered Member
 
atraperegrinus's Avatar
 
Join Date: Jun 2015
Location: Wisconsin
Posts: 490
I've had nothing but positive experiences with both products and service all of the times ive had dealings with spectrapure.

when i had issues with my ASV not working properly on my Frankenstein RODI, i only sent 2 emails within a 1 day period, and i got a phone call and i was walked through over the phone how to reroute my hoses to make everything work properly. above and beyond! i wish all companies were such a pleasure to deal with.


__________________
-Shannon

Current Tank Info: Mixed Reef - 110g Display Tank - C2C Overflow /w Bean Animal | 125g Sump/Fuge | Vertex Omega 150 | Waveline DC12000 | Apex Neptune Controller | Gyre 250's x2 | Ocean Revive LED's | SpectraPure LM3 AWC | Tunze 3155 ATO /w LM3 pump |
atraperegrinus is offline   Reply With Quote
Old 08/11/2016, 07:05 PM   #19
SpectraPure
RC Sponsor
 
SpectraPure's Avatar
 
Join Date: Jun 2003
Posts: 4,616
Thank you for the kind words.


__________________
Innovators in water technology.
Since 1985!
SpectraPure is offline   Reply With Quote
Old 08/25/2016, 04:22 PM   #20
Zalick
My reef tanks my wallet
 
Join Date: Dec 2011
Location: Portland
Posts: 292
I've called in a few times with questions about proper filters etc. Tech support on the phone is always very helpful. The product is of course top notch. And of course, Jeremy is always very helpful here in the forums.

-Todd H.


Zalick is offline   Reply With Quote
Old 09/12/2016, 02:30 PM   #21
jporter
Registered Member
 
jporter's Avatar
 
Join Date: Dec 2010
Location: Mesa, AZ
Posts: 1,368
I'm fortunate enough to live local and just pop in for filter replacements and advice. I was in a couple weeks before MACNA and Jeremy loaded me up with their new silica buster filter. Actually he replaced all filters that needed it and gave my system a complete check up. They are very helpful and full of suggestions to improve the RODI process. JP


jporter is online now   Reply With Quote
Old 09/21/2016, 12:00 PM   #22
SpectraPure
RC Sponsor
 
SpectraPure's Avatar
 
Join Date: Jun 2003
Posts: 4,616
Jeff! Thanks for the love! Let me know how everything goes!

Jeremy


__________________
Innovators in water technology.
Since 1985!
SpectraPure is offline   Reply With Quote
Old 11/04/2016, 09:58 PM   #23
Soluent1
Registered Member
 
Join Date: Aug 2016
Location: Mesa,az
Posts: 121
I recently purchased an RODI system. Upon Performing the calibration check, I found that for every 23 gallons of water I produced 1 gallon of RODI water. I called tech-support. After discussing this with the technician, I was told to bring in the unit. Since I live very nearby, it was not difficult. The person that I dealt with fixed my unit and gave me extra long outflow tubing which I wanted to water my plants..... utilizing the wastewater. I feel their support was very good and friendly. I am most happy with having purchased my unit from Spectrapure.

Also the tank in their lobby was fantastic. It was also great to see two dogs in residence. All in all, a pet friendly place.


Soluent1 is offline   Reply With Quote
Old 11/21/2016, 11:52 AM   #24
SpectraPure
RC Sponsor
 
SpectraPure's Avatar
 
Join Date: Jun 2003
Posts: 4,616
Thank you so much for the positive feedback.

Spectrapure


__________________
Innovators in water technology.
Since 1985!
SpectraPure is offline   Reply With Quote
Old 05/07/2017, 09:11 AM   #25
Kengar
Registered Member
 
Kengar's Avatar
 
Join Date: Sep 2000
Location: Gaithersburg, MD (D.C. Metro Area)
Posts: 1,770
Jeremy gave me a pretty good price for a new 200 gpd UHE unit a year and a half ago. I had been trying to get them to sell me parts to try to upgrade my existing unit to a UHE configuration, but he had steadfastly declined to do so. I'm glad I finally went with the new unit as PROPERLY configured from them. I love it and highly recommend it, and appreciate the "straight dope" they had given me re why they wouldn't simply sell parts to DIY an "upgrade."


__________________
Resident Patent Attorney
Kengar is offline   Reply With Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump


All times are GMT -6. The time now is 11:28 PM.


TapaTalk Enabled

Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2017 Axivo Inc.
Use of this web site is subject to the terms and conditions described in the user agreement.
Reef CentralTM Reef Central, LLC. Copyright 1999-2014