Reef Central Online Community

Home Forum Here you can view your subscribed threads, work with private messages and edit your profile and preferences View New Posts View Today's Posts

Find other members Frequently Asked Questions Search Reefkeeping ...an online magazine for marine aquarists Support our sponsors and mention Reef Central

Go Back   Reef Central Online Community > Sponsor Forums > Reef Breeders LEDs
Register Blogs FAQ Calendar Mark Forums Read

Notices

User Tag List

 
Thread Tools
Old 09/22/2015, 07:14 PM   #1
davidfrances
Registered Member
 
davidfrances's Avatar
 
Join Date: May 2004
Location: Parkville, MO
Posts: 686
Repair information?

Logan:

I own eight (8) of your 24" Photon units (purchased in July 2013) and two (2) of your 32" Photons. I have been very happy with your lights, and recommend them often to my friends without reservation.

Unfortunately, yesterday the white channel on one of my 24" Photons failed. The white LED's do not light under any of the program options. The blue channel seems to work fine. I understand my unit is outside of warranty.

Do you offer a repair option, and if so, can you tell me the price and expected turnaround times?

Thank you in advance for your reply. Again, I am a big fan of your products, and have been very pleased with them.

David Frances


davidfrances is offline  
Old 09/22/2015, 07:44 PM   #2
Reef_Breeders
Sponsor
 
Reef_Breeders's Avatar
 
Join Date: Jan 2013
Posts: 1,878
Hi David,

It sounds like it is likely a bad driver, to test this, you can swap the white driver for the blue driver and see if the whites turn on.

If you send us an email I can send a payment link for a new driver, they are $19.99 plus shipping past the warranty.


Reef_Breeders is offline  
Old 09/24/2015, 08:04 PM   #3
davidfrances
Registered Member
 
davidfrances's Avatar
 
Join Date: May 2004
Location: Parkville, MO
Posts: 686
Quote:
Originally Posted by Reef_Breeders View Post
Hi David,

It sounds like it is likely a bad driver, to test this, you can swap the white driver for the blue driver and see if the whites turn on.

If you send us an email I can send a payment link for a new driver, they are $19.99 plus shipping past the warranty.
Logan:

Thanks for the tip and sorry for the delay in my response. I was called out of town yesterday.

I swapped the drivers, and now neither the blue or the white channel turn on. The display seems to be working fine.

Any ideas?


davidfrances is offline  
 

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -6. The time now is 02:39 AM.


TapaTalk Enabled

Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2018 Axivo Inc.
Use of this web site is subject to the terms and conditions described in the user agreement.
Reef CentralTM Reef Central, LLC. Copyright 1999-2014
User Alert System provided by Advanced User Tagging v3.3.0 (Pro) - vBulletin Mods & Addons Copyright © 2018 DragonByte Technologies Ltd.