Reef Central Online Community

Home Forum Here you can view your subscribed threads, work with private messages and edit your profile and preferences View New Posts View Today's Posts

Find other members Frequently Asked Questions Search Reefkeeping ...an online magazine for marine aquarists Support our sponsors and mention Reef Central

Go Back   Reef Central Online Community > Sponsor Forums > Neptune Systems
Register Blogs FAQ Calendar Mark Forums Read

Notices

Reply
Thread Tools
Old 03/28/2017, 01:28 PM   #1
jonesdeini
Registered Member
 
Join Date: Nov 2013
Location: Buffalo, NY
Posts: 65
Apex customer service is <s>terrible</s> awesome

I was going to comment in the other thread but I am mad enough that I feel like this warrants its own thread.

The night before I was leaving for vacation I noticed my return pump was not running. I tried to visit apex.local and could not login. When I walked over to the apex I noticed I could hear several relays clicking outlets on and off. I immediately unplugged the apex, waited a bit, and plugged it back in. The lights when back to orange, indicating things are working fine, but I am still unable to reach apex.local. I checked to see if my router knew of any wired connections which did not belong to my computers and I did not see anything other than my computers on the network. Also my return pump and several other outlets which should be on are not. I opened a support ticket with Neptune Systems and went on vacation hoping my tank would be alright without the Apex.

I came back to what seemed to be a very reasonable response. The customer service person had me run the Apex Browser tool. The tool showed the apex having an ip of 0.0.0.0 (confirming that is not in fact on the network). The customer service person then informed me we will need to have a phone support session either 2 or 3 days from now.

It is probably just extreme bad luck that my apex broke before my vacation, but I did expect to have this resolved in a reasonable amount of time. Waiting days for them to just say I need to RMA my unit is quite frustrating, and in my opinion, unacceptable.


__________________
55G with 29G sump. 220G coming soon :D :D :D

Last edited by jonesdeini; 03/28/2017 at 02:26 PM.
jonesdeini is offline   Reply With Quote
Old 03/28/2017, 02:26 PM   #2
jonesdeini
Registered Member
 
Join Date: Nov 2013
Location: Buffalo, NY
Posts: 65
Apex got a hold of me today and got the RMA process started. It is very nice that they offer advance RMA service. I am now a happy customer! Thank you!


__________________
55G with 29G sump. 220G coming soon :D :D :D
jonesdeini is offline   Reply With Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump


All times are GMT -6. The time now is 10:53 PM.


TapaTalk Enabled

Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2017 Axivo Inc.
Use of this web site is subject to the terms and conditions described in the user agreement.
Reef CentralTM Reef Central, LLC. Copyright 1999-2014