Reef Central Online Community

Home Forum Here you can view your subscribed threads, work with private messages and edit your profile and preferences View New Posts View Today's Posts

Find other members Frequently Asked Questions Search Reefkeeping ...an online magazine for marine aquarists Support our sponsors and mention Reef Central

Go Back   Reef Central Online Community > Sponsor Forums > Royal Exclusiv / Bubble King
Register Blogs FAQ Calendar Mark Forums Read

Notices

Reply
Thread Tools
Old 10/23/2017, 09:22 AM   #1
joelk835
Registered Member
 
joelk835's Avatar
 
Join Date: Jan 2002
Location: Springfield, Mo
Posts: 406
Bubble king pump issues?

I noticed my pump had stopped on my bubble king skimmer so I took it apart and noticed this.
IMG_2540[1].jpg

IMG_2546[1].jpg

If I put the impeller back in after cleaning it works but the pictures are after cleaning with a vinegar bath. I assume that was rust that you see in the pictures it doesn't come off. Do I need to replace the whole pump or just the rotor? Also the rotor spins fine and I don't see anything particular wrong with it but are you supposed to be able to move the black plastic shield that goes between the needle and the magnet as it has some play to move it back and forth.


joelk835 is offline   Reply With Quote
Old 10/23/2017, 10:04 AM   #2
slief
RC Sponsor

 
slief's Avatar
 
Join Date: Sep 2009
Location: Simi Valley, Ca
Posts: 12,341
Quote:
Originally Posted by joelk835 View Post
I noticed my pump had stopped on my bubble king skimmer so I took it apart and noticed this.
Attachment 381496

Attachment 381497

If I put the impeller back in after cleaning it works but the pictures are after cleaning with a vinegar bath. I assume that was rust that you see in the pictures it doesn't come off. Do I need to replace the whole pump or just the rotor? Also the rotor spins fine and I don't see anything particular wrong with it but are you supposed to be able to move the black plastic shield that goes between the needle and the magnet as it has some play to move it back and forth.
Looks like you hadn't cleaned it in a while. If everything is working, I don't think you need to replace anything. I can't see the impeller very well in your picture but the staining often is the result of GFO dust collecting around the magnet and that results in the appearance of rust stains. Regular cleaning and scrubbing the magnet cavity and the impeller help prevent the staining. Some scrubbing with scotchbrite pads and a scrub brush on the plastic parts might clean it up. You could also try soaking in some diluted bleach though I don't know if that will remove the stains or not. As for the play, there is supposed to be some forward and back play on the shield between the magnet and the rotor. There is a bearing in there and it allows the magnet to float within the magnet cavity. The shield and bearing in the shield as well as the one at the base of the magnet cavity are there to center the impeller but the magnet and motor keep the magnet and impeller in the proper front to back position.


__________________
Director Customer Support Royal Exclusiv USA
For All Royal Exclusiv & Bubble King questions please refer to our Sponsor forum: http://www.reefcentral.com/forums/fo...play.php?f=745

Current Tank Info: 480G display mixed reef, 90G sump, 90G refugium, 60G display refugium. Check out my build thread: http://www.reefcentral.com/forums/showthread.php?t=1783476

Last edited by slief; 10/23/2017 at 10:10 AM.
slief is online now   Reply With Quote
Old 10/23/2017, 10:07 AM   #3
Vinny Kreyling
Registered Member
 
Vinny Kreyling's Avatar
 
Join Date: Nov 2002
Location: Miller Place, NY
Posts: 4,806
My Vectra had the same set up as far as the shield & it did have some play, this allows the shaft to settle in position.
As far as anything else I would wait for Scott to chime in.


__________________
250 gallon mixed reef, Vertex Illumina LED, RD 3 Speedy 80 Watt, DAS EX-3 Skimmer, MTC mini cal, 2-3/4" Sea Swirls, Aquacontroller & 4 Tunze pumps.
Vinny Kreyling is offline   Reply With Quote
Old 10/23/2017, 10:08 AM   #4
Vinny Kreyling
Registered Member
 
Vinny Kreyling's Avatar
 
Join Date: Nov 2002
Location: Miller Place, NY
Posts: 4,806
Hi Scott --


__________________
250 gallon mixed reef, Vertex Illumina LED, RD 3 Speedy 80 Watt, DAS EX-3 Skimmer, MTC mini cal, 2-3/4" Sea Swirls, Aquacontroller & 4 Tunze pumps.
Vinny Kreyling is offline   Reply With Quote
Old 10/23/2017, 10:10 AM   #5
slief
RC Sponsor

 
slief's Avatar
 
Join Date: Sep 2009
Location: Simi Valley, Ca
Posts: 12,341
Quote:
Originally Posted by Vinny Kreyling View Post
Hi Scott --



__________________
Director Customer Support Royal Exclusiv USA
For All Royal Exclusiv & Bubble King questions please refer to our Sponsor forum: http://www.reefcentral.com/forums/fo...play.php?f=745

Current Tank Info: 480G display mixed reef, 90G sump, 90G refugium, 60G display refugium. Check out my build thread: http://www.reefcentral.com/forums/showthread.php?t=1783476
slief is online now   Reply With Quote
Old 10/23/2017, 10:16 AM   #6
joelk835
Registered Member
 
joelk835's Avatar
 
Join Date: Jan 2002
Location: Springfield, Mo
Posts: 406
Thanks guys.


joelk835 is offline   Reply With Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -6. The time now is 01:57 AM.


TapaTalk Enabled

Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2017 Axivo Inc.
Use of this web site is subject to the terms and conditions described in the user agreement.
Reef CentralTM Reef Central, LLC. Copyright 1999-2014